summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-10 12:08:30 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-10 12:19:38 +0000
commit2dcff97b0f0973f792e22a534c97811b3267472b (patch)
tree25f3a11e6db88c23543d918d3cbdc62617ec07f4 /dev-games/irrlicht-mt
parentdev-games/irrlicht-mt-headers: initial import (diff)
downloadgentoo-2dcff97b0f0973f792e22a534c97811b3267472b.tar.gz
gentoo-2dcff97b0f0973f792e22a534c97811b3267472b.tar.bz2
gentoo-2dcff97b0f0973f792e22a534c97811b3267472b.zip
dev-games/irrlicht-mt: headers live in a separate package now
Note that src_compile still uses bundled headers. This is intentional - if they are not the same as those from dev-games/irrlicht-mt-headers something is SERIOUSLY wrong, and that way we do not have to mess with build scripts. Closes: https://bugs.gentoo.org/833052 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-games/irrlicht-mt')
-rw-r--r--dev-games/irrlicht-mt/irrlicht-mt-1.9.0.4-r1.ebuild (renamed from dev-games/irrlicht-mt/irrlicht-mt-1.9.0.4.ebuild)12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-games/irrlicht-mt/irrlicht-mt-1.9.0.4.ebuild b/dev-games/irrlicht-mt/irrlicht-mt-1.9.0.4-r1.ebuild
index 34b915793472..15ffef6d4c61 100644
--- a/dev-games/irrlicht-mt/irrlicht-mt-1.9.0.4.ebuild
+++ b/dev-games/irrlicht-mt/irrlicht-mt-1.9.0.4-r1.ebuild
@@ -17,7 +17,8 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-RDEPEND="media-libs/libpng:0=
+RDEPEND="~dev-games/irrlicht-mt-headers-${PV}
+ media-libs/libpng:0=
sys-libs/zlib
virtual/jpeg:0
virtual/opengl
@@ -26,4 +27,11 @@ RDEPEND="media-libs/libpng:0=
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}"/${MY_P}
+
+src_install() {
+ cmake_src_install
+
+ # We package these separately
+ rm -r "${ED}"/usr/include/${PN/-/} || die "Failed to exclude header files from installation"
+}