summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 11:38:03 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 11:43:15 +0100
commit9c8050b633b053ddc5564cdc39297689f7ddb165 (patch)
tree0f80b9d26fbc37c74d746d37a8aa1a1ee0bc0873 /dev-games/mygui
parentsci-visualization/paraview: [QA] Run cmake-utils_src_prepare (diff)
downloadgentoo-9c8050b633b053ddc5564cdc39297689f7ddb165.tar.gz
gentoo-9c8050b633b053ddc5564cdc39297689f7ddb165.tar.bz2
gentoo-9c8050b633b053ddc5564cdc39297689f7ddb165.zip
dev-games/mygui: [QA] Run cmake-utils_src_prepare
Closes: https://bugs.gentoo.org/639436 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-games/mygui')
-rw-r--r--dev-games/mygui/mygui-3.2.2.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-games/mygui/mygui-3.2.2.ebuild b/dev-games/mygui/mygui-3.2.2.ebuild
index 60ec5b14954f..3755ef1f7122 100644
--- a/dev-games/mygui/mygui-3.2.2.ebuild
+++ b/dev-games/mygui/mygui-3.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -36,6 +36,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/mygui-${MY_P}
STATIC_BUILD=${WORKDIR}/${P}_build_static
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-FHS.patch
+)
+
pkg_setup() {
if use samples && use !ogre ; then
ewarn "Samples disabled, because they only work with ogre!"
@@ -43,12 +49,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-underlinking.patch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-FHS.patch
-}
-
src_configure() {
use debug && append-cppflags -DDEBUG
@@ -129,14 +129,14 @@ src_install() {
fperms o+w /etc/MYGUI
# test media not needed at runtime
- rm -rf "${D}"/usr/share/MYGUI/Media/UnitTests
+ rm -rf "${ED%/}"/usr/share/MYGUI/Media/UnitTests || die
# wrapper not available for linux, remove related media
- rm -rf "${D}"/usr/share/MYGUI/Media/Wrapper
+ rm -rf "${ED%/}"/usr/share/MYGUI/Media/Wrapper || die
}
pkg_postinst() {
- einfo
+ elog
elog "ogre.cfg and Ogre.log are created as"
- elog "/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
- einfo
+ elog "${EROOT%/}/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
+ elog
}