summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/paklib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/paklib')
-rw-r--r--dev-games/paklib/Manifest1
-rw-r--r--dev-games/paklib/metadata.xml8
-rw-r--r--dev-games/paklib/paklib-0.3.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-games/paklib/Manifest b/dev-games/paklib/Manifest
new file mode 100644
index 000000000000..a5651eeffe55
--- /dev/null
+++ b/dev-games/paklib/Manifest
@@ -0,0 +1 @@
+DIST pak-0.3.tar.gz 12885 SHA256 6139688e96d044386ac92e587791bf29d0adc501240765bb08fe4b00f31cf6c9 SHA512 05eb8402fc1b1b0ab381dbf815c59fa1fde1e1aa081c124d0f2f3b257fdefd23e9c7995c055b368f53dabab60722b6505976bc601d991265581ee36cb96b7750 WHIRLPOOL 982cebeb1f48ecd0099f694f00ebcf292968fa1710b6b1020e760fbdcf95e70cdccc7caed75a65ead3b856839fe84f89c090e25b772f0d3de387ea5c7068d821
diff --git a/dev-games/paklib/metadata.xml b/dev-games/paklib/metadata.xml
new file mode 100644
index 000000000000..8d14a6674949
--- /dev/null
+++ b/dev-games/paklib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">paklib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-games/paklib/paklib-0.3.ebuild b/dev-games/paklib/paklib-0.3.ebuild
new file mode 100644
index 000000000000..46d7f006d7dc
--- /dev/null
+++ b/dev-games/paklib/paklib-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="library for accessing Quake pak files"
+HOMEPAGE="http://sourceforge.net/projects/paklib/"
+SRC_URI="mirror://sourceforge/paklib/pak-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/pak
+
+src_compile() {
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} -fPIC -shared pak.c -o libpak.so || die "pak.so failed"
+ $(tc-getCC) ${CFLAGS} -c pak.c -o libpak.a || die "pak.a failed"
+}
+
+src_install() {
+ dolib.so libpak.so
+ dolib.a libpak.a
+ insinto /usr/include
+ doins pak.h
+ dodoc AUTHORS NEWS README TODO pak.c pak.h
+}