summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-25 06:17:54 +0000
committerSam James <sam@gentoo.org>2021-02-25 06:36:06 +0000
commit5a450f7cbe88f98d4ec320e60177cdd3800a937e (patch)
tree020f14a95287a26a165ac16d60d774169b43fa65 /dev-games
parentdev-games/clanlib: minor touchups (diff)
downloadgentoo-5a450f7cbe88f98d4ec320e60177cdd3800a937e.tar.gz
gentoo-5a450f7cbe88f98d4ec320e60177cdd3800a937e.tar.bz2
gentoo-5a450f7cbe88f98d4ec320e60177cdd3800a937e.zip
dev-games/clanlib: port 2.3.7 to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/clanlib-2.3.7-r1.ebuild104
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-autotools.patch8
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-doc.patch4
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch4
4 files changed, 112 insertions, 8 deletions
diff --git a/dev-games/clanlib/clanlib-2.3.7-r1.ebuild b/dev-games/clanlib/clanlib-2.3.7-r1.ebuild
new file mode 100644
index 000000000000..824f8a34c6d6
--- /dev/null
+++ b/dev-games/clanlib/clanlib-2.3.7-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+MY_P=ClanLib-${PV}
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="2.3"
+# Not big endian safe! #82779
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6 mikmod opengl sound sqlite cpu_flags_x86_sse2 static-libs vorbis X"
+REQUIRED_USE="opengl? ( X )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen dev-lang/perl )
+"
+RDEPEND="
+ sys-libs/zlib
+ X? (
+ app-arch/bzip2
+ media-libs/libpng:0
+ media-libs/freetype
+ media-libs/fontconfig
+ virtual/jpeg:0
+ x11-libs/libX11
+ opengl? ( virtual/opengl )
+ )
+ mikmod? (
+ media-libs/alsa-lib
+ media-libs/libmikmod
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ sound? ( media-libs/alsa-lib )
+ vorbis? (
+ media-libs/alsa-lib
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-doc.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch #764902
+)
+
+DOCS=( CODING_STYLE CREDITS PATCHES README )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ ln -sf ../../../Sources/API Documentation/Utilities/ReferenceDocs/ClanLib || die
+}
+
+src_configure() {
+ # Add -DPACKAGE_BUGREPORT?
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanGL1)
+ $(use_enable opengl clanGUI)
+ $(use_enable X clanDisplay)
+ $(use_enable vorbis clanVorbis)
+ $(use_enable mikmod clanMikMod)
+ $(use_enable sqlite clanSqlite)
+ $(use_enable ipv6 getaddr)
+ )
+
+ use sound \
+ || use vorbis \
+ || use mikmod \
+ || myeconfargs+=( --disable-clanSound )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+
+ use doc && emake html
+}
+
+# html files are keeped in a directory that is dependent on the SLOT
+# so to keep eventual bookmarks to the doc from version to version
+src_install() {
+ default
+
+ if use doc ; then
+ emake DESTDIR="${D}" install-html
+ dodoc -r Examples Resources
+ fi
+}
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
index 97db79ac4245..eccc7e291323 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
@@ -1,5 +1,5 @@
---- Documentation/Reference/Makefile.am.old 2012-09-25 10:39:25.973544935 +0200
-+++ Documentation/Reference/Makefile.am 2012-09-25 10:39:42.560554053 +0200
+--- a/Documentation/Reference/Makefile.am
++++ b/Documentation/Reference/Makefile.am
@@ -10,7 +10,7 @@
mkdir doxyoutput;
mkdir reftest
@@ -9,8 +9,8 @@
../Utilities/ReferenceDocs/ReferenceDocs
install-html:
---- configure.ac.old 2012-09-25 11:07:38.412537590 +0200
-+++ configure.ac 2012-09-25 11:09:41.133939131 +0200
+--- a/configure.ac
++++ b/configure.ac
@@ -337,11 +337,9 @@
dnl Optional linux/joystick.h
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
index 627df26785b4..d207f2df3cca 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
@@ -1,5 +1,5 @@
---- Documentation/Utilities/ReferenceDocs/Makefile.old 2014-09-12 20:06:52.970459560 +0200
-+++ Documentation/Utilities/ReferenceDocs/Makefile 2014-09-12 20:08:17.387048685 +0200
+--- a/Documentation/Utilities/ReferenceDocs/Makefile
++++ b/Documentation/Utilities/ReferenceDocs/Makefile
@@ -3,7 +3,10 @@
LIBS=clanCore
EXTRA_LIBS=-lpthread
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch b/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
index 47a1c89b2405..d10a3b0085ad 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
@@ -1,7 +1,7 @@
https://bugs.gentoo.org/764902
---- ClanLib-2.3.7/configure.ac
-+++ ClanLib-2.3.7/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -342,7 +342,7 @@
echo "=============================="
CLANLIB_CHECK_LIB(png, [`cat $srcdir/Setup/Tests/png.cpp`], clanDisplay, [ *** Cannot find png (See http://www.libpng.org ) (Try libpng12-dev or better) ], [-lz -lpng])