summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 08:50:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-28 09:49:43 -0400
commit72f36fac887a709689cc341d09164def720751f6 (patch)
tree468aaa2aed46ecd6758d7cc94f1ed4b218232a9e /dev-games
parentdev-python/trio: add missing test dep (diff)
downloadgentoo-72f36fac887a709689cc341d09164def720751f6.tar.gz
gentoo-72f36fac887a709689cc341d09164def720751f6.tar.bz2
gentoo-72f36fac887a709689cc341d09164def720751f6.zip
dev-games/godot: add 3.5.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/Manifest1
-rw-r--r--dev-games/godot/godot-3.5.1.ebuild218
2 files changed, 219 insertions, 0 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index d71893f50aeb..9e96f4de45d0 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,2 +1,3 @@
DIST godot-3.5-stable.tar.xz 24044340 BLAKE2B 9d77ecdfa6bd90065fff26c2334f13c32bbbc4b26aad111b5aab2563d1e4782457ea6cf2115f1a809e0d8aac3d3ee9a138ad224998068983ad36e54a577d89c3 SHA512 23785e39ccc7e1406c97ee33b5e90f7f397aa907d79d72ed08ea3f4b7e68788030a1bcdd07c9f782a21ee3a84636a2cea47a57dcfc94c24e327fa210ae0515b0
+DIST godot-3.5.1-stable.tar.xz 24153448 BLAKE2B 9d61276a2d82ef4f4487ec1046b7fa58f2b3626640b2db25c1f98c3f8e2ff40eddcf943fd9ffaaf6814fbafbbe7ef1d3f642d77af953b87731cff570ac3a5473 SHA512 59e5ca88534f542562971efb83b76561705f9ca8761311f01b4453857e7ae046c17cadd0d5ca6f6f56e262b5031294a8b9ad970fa6ffc95e1a6a1e1bae48d55f
DIST godot-4.0-beta1.tar.xz 31113892 BLAKE2B b7adc96ea9d19b962833bb3244f464151a08befb1301dbd147f421c8fb649dcb645656e0982aebaec695988c29e763f52456fa7e23a52b64cfddf39866f2c0af SHA512 86babe6bcd960f3e911b309de39145535f8755ffb64ba024315eab253803d78049020a6f7362318b9e29ba27527e479fba95a20db686ec854ba0a377a276d467
diff --git a/dev-games/godot/godot-3.5.1.ebuild b/dev-games/godot/godot-3.5.1.ebuild
new file mode 100644
index 000000000000..3d18204a94a1
--- /dev/null
+++ b/dev-games/godot/godot-3.5.1.ebuild
@@ -0,0 +1,218 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 desktop python-any-r1 scons-utils toolchain-funcs xdg
+
+DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
+HOMEPAGE="https://godotengine.org/"
+SRC_URI="https://downloads.tuxfamily.org/godotengine/${PV}/${P}-stable.tar.xz"
+S="${WORKDIR}/${P}-stable"
+
+LICENSE="
+ MIT
+ Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
+ gui? ( CC-BY-4.0 ) tools? ( BitstreamVera OFL-1.1 )"
+SLOT="3"
+KEYWORDS="~amd64"
+# Enable roughly same as upstream by default so it works as expected,
+# except raycast (tools-only heavy dependency), and deprecated.
+IUSE="
+ +bullet debug deprecated +gui pulseaudio raycast +runner +theora
+ +tools +udev +upnp +webm +webp"
+
+# dlopen: alsa-lib,pulseaudio,udev
+RDEPEND="
+ app-arch/zstd:=
+ dev-games/recastnavigation:=
+ dev-libs/libpcre2:=[pcre32]
+ media-libs/freetype[brotli]
+ media-libs/libpng:=
+ <net-libs/mbedtls-3:=
+ net-libs/wslay
+ sys-libs/zlib:=
+ bullet? ( sci-physics/bullet:= )
+ gui? (
+ media-libs/alsa-lib
+ media-libs/libglvnd[X]
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ pulseaudio? ( media-libs/libpulse )
+ tools? ( raycast? ( media-libs/embree:3 ) )
+ udev? ( virtual/udev )
+ )
+ theora? (
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+ )
+ tools? ( app-misc/ca-certificates )
+ upnp? ( net-libs/miniupnpc:= )
+ webm? (
+ media-libs/libvorbis
+ media-libs/libvpx:=
+ media-libs/opus
+ )
+ webp? ( media-libs/libwebp:= )"
+DEPEND="
+ ${RDEPEND}
+ gui? ( x11-base/xorg-proto )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-musl.patch
+ "${FILESDIR}"/${PN}-3.5-scons.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
+ sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
+ sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
+ -i misc/dist/linux/org.godotengine.Godot.desktop || die
+
+ sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/{x11,server}/detect.py || die
+
+ # use of builtin_ switches can be messy (see below), delete to be sure
+ local unbundle=(
+ bullet embree freetype libogg libpng libtheora libvorbis libvpx
+ libwebp mbedtls miniupnpc opus pcre2 recastnavigation wslay zlib zstd
+ # certs: unused by generated header, but scons panics if not found
+ )
+ rm -r "${unbundle[@]/#/thirdparty/}" || die
+}
+
+src_compile() {
+ local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
+
+ local esconsargs=(
+ AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+
+ platform=$(usex gui x11 server)
+ progress=no
+ verbose=yes
+
+ deprecated=$(usex deprecated)
+ #execinfo=$(usex !elibc_glibc) # libexecinfo is not packaged
+ minizip=yes # uses a modified bundled copy
+ pulseaudio=$(usex gui $(usex pulseaudio))
+ udev=$(usex gui $(usex udev))
+
+ system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+
+ # platform/*/detect.py uses builtin_* switches to check if need
+ # to link with system libraries, but ignores whether the dep is
+ # actually used, so "enable" deleted builtins on disabled deps
+ builtin_bullet=$(usex !bullet)
+ builtin_certs=no
+ builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
+ builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
+ builtin_freetype=no
+ builtin_libogg=yes # unused
+ builtin_libpng=no
+ builtin_libtheora=$(usex !theora)
+ builtin_libvorbis=$(usex !theora $(usex !webm))
+ builtin_libvpx=$(usex !webm)
+ builtin_libwebp=$(usex !webp)
+ builtin_mbedtls=no
+ builtin_miniupnpc=$(usex !upnp)
+ builtin_opus=$(usex !webm)
+ builtin_pcre2=no
+ builtin_recast=no
+ builtin_rvo2=yes # bundled copy has godot-specific changes
+ builtin_squish=yes # ^ likewise, may not be safe to unbundle
+ builtin_wslay=no
+ builtin_xatlas=yes # not wired for unbundling nor packaged
+ builtin_zlib=no
+ builtin_zstd=no
+ # also bundled but lacking a builtin_* switch:
+ # cvtt, etc2comp, fonts, glad, jpeg-compressor, libsimplewebm,
+ # minimp3, minizip (patched to seek in archives), nanosvg, oidn,
+ # pvrtccompressor, stb_rect_pack, tinyexr, vhacd, and the misc
+ # directory.
+
+ # modules with optional dependencies, "possible" to disable more but
+ # gets messy and breaks all sorts of features (expected enabled)
+ module_bullet_enabled=$(usex bullet)
+ module_mono_enabled=no # unhandled
+ module_ogg_enabled=no # unused
+ module_opus_enabled=no # unused, support is gone and webm uses system's
+ # note raycast is disabled on many arches, see raycast/config.py
+ module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
+ module_theora_enabled=$(usex theora)
+ module_upnp_enabled=$(usex upnp)
+ module_vorbis_enabled=no # unused, non-theora/webm uses stb_vorbis
+ module_webm_enabled=$(usex webm)
+ module_webp_enabled=$(usex webp)
+
+ # let *FLAGS handle these, e.g. can pass -flto as-is
+ debug_symbols=no
+ optimize=none
+ use_lto=no
+ use_static_cpp=no
+ )
+
+ if use runner && use tools; then
+ # build alternate faster + ~60% smaller binary for running
+ # games or servers without game development debug paths
+ escons extra_suffix=runner target=release tools=no "${esconsargs[@]}"
+ fi
+
+ esconsargs+=(
+ # debug: debug for godot itself
+ # release_debug: debug for game development
+ # release: no debugging paths, only available with tools=no
+ target=$(usex debug{,} $(usex tools release_debug release))
+ tools=$(usex tools)
+ )
+
+ escons extra_suffix=main "${esconsargs[@]}"
+}
+
+src_install() {
+ local s=godot${SLOT}
+
+ newbin bin/godot*.main ${s}
+ if use runner && use tools; then
+ newbin bin/godot*.runner ${s}-runner
+ else
+ # always available, revdeps shouldn't depend on [runner]
+ dosym ${s} /usr/bin/${s}-runner
+ fi
+
+ newman misc/dist/linux/godot.6 ${s}.6
+ dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
+
+ if use gui; then
+ newicon icon.svg ${s}.svg
+ newmenu misc/dist/linux/org.godotengine.Godot.desktop \
+ org.godotengine.${s^}.desktop
+
+ insinto /usr/share/metainfo
+ newins misc/dist/linux/org.godotengine.Godot.appdata.xml \
+ org.godotengine.${s^}.appdata.xml
+
+ insinto /usr/share/mime/application
+ newins misc/dist/linux/org.godotengine.Godot.xml \
+ org.godotengine.${s^}.xml
+ fi
+
+ newbashcomp misc/dist/shell/godot.bash-completion ${s}
+ bashcomp_alias ${s}{,-runner}
+
+ insinto /usr/share/fish/vendor_completions.d
+ newins misc/dist/shell/godot.fish ${s}.fish
+ dosym ${s}.fish /usr/share/fish/vendor_completions.d/${s}-runner.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins misc/dist/shell/_godot.zsh-completion _${s}
+ dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
+}