summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-21 21:38:04 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-21 21:38:04 +0100
commit74010217b98ba7f20211a93b53a34334893fa360 (patch)
tree87a439e1ef6407da01aa601b09f0207332bdda98 /dev-games
parentgames-arcade/spout: Port to EAPI 7 (diff)
downloadgentoo-74010217b98ba7f20211a93b53a34334893fa360.tar.gz
gentoo-74010217b98ba7f20211a93b53a34334893fa360.tar.bz2
gentoo-74010217b98ba7f20211a93b53a34334893fa360.zip
dev-games/t4k-common: Port to EAPI 7
Closes: https://bugs.gentoo.org/707168 Closes: https://bugs.gentoo.org/715574 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch10
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch11
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch4
-rw-r--r--dev-games/t4k-common/t4k-common-0.1.1.ebuild33
4 files changed, 46 insertions, 12 deletions
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch
new file mode 100644
index 000000000000..037d2acd292b
--- /dev/null
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-ICONV_CONST.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,6 +39,7 @@
+ AC_PROG_MKDIR_P
+ AC_PROG_YACC
+ AC_PROG_LIBTOOL
++AM_ICONV
+
+
+ # -----------------------------------------------------------------------
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch
new file mode 100644
index 000000000000..2bdf418649c2
--- /dev/null
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/t4k_common.h
++++ b/src/t4k_common.h
+@@ -239,7 +239,7 @@
+ #define MAX_LINES 128 //!< Maximum lines to wrap.
+ #define MAX_LINEWIDTH 256 //!< Maximum characters of each line.
+
+-char wrapped_lines[MAX_LINES][MAX_LINEWIDTH]; //!< Global buffer for wrapped lines.
++extern char wrapped_lines[MAX_LINES][MAX_LINEWIDTH]; //!< Global buffer for wrapped lines.
+
+ //TODO separate headers for different areas a la SDL?
+
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
index 29991544ddbf..fad91de2d205 100644
--- a/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
@@ -1,5 +1,5 @@
---- src/t4k_common-0.1.1/src/t4k_loaders.c 2011-04-08 05:46:07.000000000 +0300
-+++ src.new/t4k_common-0.1.1/src/t4k_loaders.c 2012-05-02 10:35:41.836670434 +0300
+--- a/src/t4k_loaders.c
++++ b/src/t4k_loaders.c
@@ -1028,12 +1028,9 @@
{
png_init_io(png_ptr, fi);
diff --git a/dev-games/t4k-common/t4k-common-0.1.1.ebuild b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
index 3c366660d4d6..e0a6d5009ab5 100644
--- a/dev-games/t4k-common/t4k-common-0.1.1.ebuild
+++ b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils ltprune
+EAPI=7
+
+inherit autotools
DESCRIPTION="A library of code shared between tuxmath and tuxtype"
HOMEPAGE="https://github.com/tux4kids/t4kcommon"
@@ -11,9 +12,10 @@ SRC_URI="https://github.com/tux4kids/t4kcommon/archive/upstream/${PV}.tar.gz ->
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static-libs svg"
+IUSE="svg"
-RDEPEND="dev-libs/libxml2:2
+RDEPEND="
+ dev-libs/libxml2:2
media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-mixer
@@ -25,22 +27,33 @@ RDEPEND="dev-libs/libxml2:2
media-libs/libpng:0
x11-libs/cairo
)"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+# need sys-devel/gettext for AM_ICONV in iconv.m4
+BDEPEND="
+ sys-devel/gettext
virtual/pkgconfig"
-S=${WORKDIR}/t4kcommon-upstream-${PV}
+S="${WORKDIR}/t4kcommon-upstream-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libpng.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-ICONV_CONST.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-libpng.patch
+ default
+ rm m4/iconv.m4 || die
+ eautoreconf
}
src_configure() {
econf \
- $(usex svg "" "--without-rsvg") \
- $(use_enable static-libs static)
+ --disable-static \
+ $(usex svg "" --without-rsvg)
}
src_install() {
default
- use static-libs || prune_libtool_files --all
+ find "${ED}" -name '*.la' -delete || die
}