summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 03:59:15 +0000
committerSam James <sam@gentoo.org>2021-04-19 04:30:50 +0000
commitaa8e06c74de46bcaad4130ed4983e47bf4c4d72a (patch)
treee9de3b956707b6f2b6a0da20e9e4e8030ba95a56 /dev-games
parentgames-strategy/triplea: port to EAPI 7 (diff)
downloadgentoo-aa8e06c74de46bcaad4130ed4983e47bf4c4d72a.tar.gz
gentoo-aa8e06c74de46bcaad4130ed4983e47bf4c4d72a.tar.bz2
gentoo-aa8e06c74de46bcaad4130ed4983e47bf4c4d72a.zip
dev-games/mercator: port to EAPI 7, ltprune--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/mercator/mercator-0.3.3.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/dev-games/mercator/mercator-0.3.3.ebuild b/dev-games/mercator/mercator-0.3.3.ebuild
index 34cbfc3fe787..3a4046872aca 100644
--- a/dev-games/mercator/mercator-0.3.3.ebuild
+++ b/dev-games/mercator/mercator-0.3.3.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit ltprune
+EAPI=7
DESCRIPTION="WorldForge library primarily aimed at terrain"
HOMEPAGE="https://www.worldforge.org/index.php/components/mercator/"
SRC_URI="mirror://sourceforge/worldforge/${P}.tar.gz"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 x86"
IUSE="doc"
-SLOT="0"
RDEPEND=">=dev-games/wfmath-1"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
doc? ( app-doc/doxygen )
- virtual/pkgconfig"
+"
src_compile() {
default
@@ -25,6 +26,11 @@ src_compile() {
src_install() {
default
- use doc && dohtml -r doc/html/*
- prune_libtool_files
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/html/*
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
}