summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-16 09:58:31 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-16 09:59:04 +0200
commitab50cee0aa0115a8cd9a978d4eee87f3e3f3794e (patch)
treeb1ee0467ccbecccc7f16786d881ae9a7cb89fa7d /dev-games
parentgames-rpg/sumwars: treeclean (diff)
downloadgentoo-ab50cee0aa0115a8cd9a978d4eee87f3e3f3794e.tar.gz
gentoo-ab50cee0aa0115a8cd9a978d4eee87f3e3f3794e.tar.bz2
gentoo-ab50cee0aa0115a8cd9a978d4eee87f3e3f3794e.zip
dev-games/cegui: treeclean
Closes: https://bugs.gentoo.org/896688 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/cegui/Manifest1
-rw-r--r--dev-games/cegui/cegui-0.8.7-r100.ebuild126
-rw-r--r--dev-games/cegui/files/cegui-0.8.7-icu-59.patch11
-rw-r--r--dev-games/cegui/files/cegui-0.8.7-musl.patch72
-rw-r--r--dev-games/cegui/files/cegui-0.8.7-python3.patch21
-rw-r--r--dev-games/cegui/metadata.xml20
6 files changed, 0 insertions, 251 deletions
diff --git a/dev-games/cegui/Manifest b/dev-games/cegui/Manifest
deleted file mode 100644
index 8f032e272ef5..000000000000
--- a/dev-games/cegui/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cegui-0.8.7.tar.bz2 18114465 BLAKE2B cf0a4867f0e32c6a6b585821c915dc1fbd532e0f95effe28f6d3e4f1a2bccd23f47c7c33a3115befdf8b3f094d49a5af042d28c1e1fbb88e7c7f6da7f3fa173b SHA512 271ff2a1e19f46c7d40cbc210bc665666e45b56cd0efea460db4d08df134d929337846eaf923db1b915597965aab27ad39512d6567cc63ef883555cbff542e56
diff --git a/dev-games/cegui/cegui-0.8.7-r100.ebuild b/dev-games/cegui/cegui-0.8.7-r100.ebuild
deleted file mode 100644
index 6e55a6b40bcc..000000000000
--- a/dev-games/cegui/cegui-0.8.7-r100.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# TODO: multiple ABI?
-LUA_COMPAT=( lua5-1 )
-PYTHON_COMPAT=( python3_{9..10} )
-inherit flag-o-matic cmake lua-single python-single-r1
-
-DESCRIPTION="Crazy Eddie's GUI System"
-HOMEPAGE="http://www.cegui.org.uk/"
-SRC_URI="mirror://sourceforge/crayzedsgui/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bidi debug devil doc freeimage expat irrlicht lua ogre opengl pcre python static-libs tinyxml truetype xerces-c +xml zip"
-REQUIRED_USE="|| ( expat tinyxml xerces-c xml )
- lua? ( ${LUA_REQUIRED_USE} )
- python? ( ${PYTHON_REQUIRED_USE} )" # bug 362223
-
-# gles broken
-# gles? ( media-libs/mesa[gles1] )
-# directfb broken
-# directfb? ( dev-libs/DirectFB )
-RDEPEND="
- dev-libs/boost:=
- virtual/libiconv
- bidi? ( dev-libs/fribidi )
- devil? ( media-libs/devil )
- expat? ( dev-libs/expat )
- freeimage? ( media-libs/freeimage )
- irrlicht? ( dev-games/irrlicht )
- lua? (
- ${LUA_DEPS}
- dev-lua/toluapp[${LUA_SINGLE_USEDEP}]
- )
- ogre? ( >=dev-games/ogre-1.7:= )
- opengl? (
- virtual/opengl
- virtual/glu
- media-libs/glew:=
- )
- pcre? ( dev-libs/libpcre )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- ')
- )
- tinyxml? ( dev-libs/tinyxml )
- truetype? ( media-libs/freetype:2 )
- xerces-c? ( dev-libs/xerces-c )
- xml? ( dev-libs/libxml2:2 )
- zip? ( sys-libs/zlib[minizip] )"
-
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- opengl? ( media-libs/glm )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-icu-59.patch
- "${FILESDIR}"/${P}-python3.patch
- "${FILESDIR}"/${P}-musl.patch
-)
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- # http://www.cegui.org.uk/mantis/view.php?id=991
- append-ldflags $(no-as-needed)
-
- local mycmakeargs=(
- -DCEGUI_BUILD_IMAGECODEC_CORONA=OFF
- -DCEGUI_BUILD_IMAGECODEC_DEVIL=$(usex devil)
- -DCEGUI_BUILD_IMAGECODEC_FREEIMAGE=$(usex freeimage)
- -DCEGUI_BUILD_IMAGECODEC_PVR=OFF
- -DCEGUI_BUILD_IMAGECODEC_SILLY=OFF
- -DCEGUI_BUILD_IMAGECODEC_STB=ON
- -DCEGUI_BUILD_IMAGECODEC_TGA=ON
- -DCEGUI_BUILD_LUA_GENERATOR=$(usex lua)
- -DCEGUI_BUILD_LUA_MODULE=$(usex lua)
- -DCEGUI_BUILD_PYTHON_MODULES=$(usex python)
- -DCEGUI_BUILD_RENDERER_DIRECTFB=OFF
- -DCEGUI_BUILD_RENDERER_IRRLICHT=$(usex irrlicht)
- -DCEGUI_BUILD_RENDERER_NULL=ON
- -DCEGUI_BUILD_RENDERER_OGRE=$(usex ogre)
- -DCEGUI_BUILD_RENDERER_OPENGL=$(usex opengl)
- -DCEGUI_BUILD_RENDERER_OPENGL3=$(usex opengl)
- -DCEGUI_BUILD_RENDERER_OPENGLES=OFF
- -DCEGUI_BUILD_STATIC_CONFIGURATION=$(usex static-libs)
- -DCEGUI_BUILD_TESTS=OFF
- -DCEGUI_BUILD_XMLPARSER_EXPAT=$(usex expat)
- -DCEGUI_BUILD_XMLPARSER_LIBXML2=$(usex xml)
- -DCEGUI_BUILD_XMLPARSER_RAPIDXML=OFF
- -DCEGUI_BUILD_XMLPARSER_TINYXML=$(usex tinyxml)
- -DCEGUI_BUILD_XMLPARSER_XERCES=$(usex xerces-c)
- -DCEGUI_HAS_FREETYPE=$(usex truetype)
- -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=$(usex zip)
- -DCEGUI_HAS_PCRE_REGEX=$(usex pcre)
- -DCEGUI_SAMPLES_ENABLED=OFF
- -DCEGUI_USE_FRIBIDI=$(usex bidi)
- -DCEGUI_USE_MINIBIDI=OFF
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile all $(usex doc html "")
-}
-
-src_install() {
- cmake_src_install
- docinto html
- use doc && dodoc -r "${BUILD_DIR}"/doc/doxygen/html/*
-}
diff --git a/dev-games/cegui/files/cegui-0.8.7-icu-59.patch b/dev-games/cegui/files/cegui-0.8.7-icu-59.patch
deleted file mode 100644
index e64dfc97ab59..000000000000
--- a/dev-games/cegui/files/cegui-0.8.7-icu-59.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -72,7 +72,7 @@
-
- if ((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR (CMAKE_CXX_COMPILER_ID STREQUAL "Clang"))
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")
-- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++03")
-+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
- elseif (NOT CMAKE_VERSION VERSION_LESS "3.1")
- set (CMAKE_C_STANDARD_REQUIRED TRUE)
- set (CMAKE_C_STANDARD "99")
diff --git a/dev-games/cegui/files/cegui-0.8.7-musl.patch b/dev-games/cegui/files/cegui-0.8.7-musl.patch
deleted file mode 100644
index 6eb62018dcfc..000000000000
--- a/dev-games/cegui/files/cegui-0.8.7-musl.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From e7611d3ef0b9ab2e00f485030234dea3a58c7aa4 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 16 May 2020 20:07:02 +0100
-Subject: [PATCH] Fix debug build and rework Exceptions includes logic
-
-Commit 3ddf92058392 broke the debug build. HAVE_EXECINFO_H is never
-defined by the build system so this header is never included, even
-when it is needed by the debug code.
-
-The right way to fix this is only to include these headers when debug
-is actually enabled. This does mean that the debug build is still
-broken under musl but fixing that would require using libunwind
-instead.
----
- cegui/src/Exceptions.cpp | 16 ++++------------
- 1 file changed, 4 insertions(+), 12 deletions(-)
-
-diff --git a/cegui/src/Exceptions.cpp b/cegui/src/Exceptions.cpp
-index 138081a..934989e 100644
---- a/cegui/src/Exceptions.cpp
-+++ b/cegui/src/Exceptions.cpp
-@@ -33,12 +33,13 @@
-
- #if defined( __WIN32__ ) || defined( _WIN32)
- # include <windows.h>
-+#elif defined(__ANDROID__)
-+# include <android/log.h>
- #endif
-
-+#if defined(_DEBUG) || defined(DEBUG)
- #if defined(_MSC_VER)
- # include <dbghelp.h>
--#elif defined(__ANDROID__)
--# include <android/log.h>
- #elif (defined(__linux__) && !defined(__ANDROID__)) \
- || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) \
- || defined(__HAIKU__)
-@@ -47,6 +48,7 @@
- # include <cxxabi.h>
- # include <cstdlib>
- #endif
-+#endif
-
- // Start of CEGUI namespace section
- namespace CEGUI
-@@ -57,14 +59,6 @@ bool Exception::d_stdErrEnabled(true);
- //----------------------------------------------------------------------------//
- static void dumpBacktrace(size_t frames)
- {
--
--#if defined(__ANDROID__)
--
-- // Not implemented yet.
-- CEGUI_UNUSED(frames);
--
--#else
--
- #if defined(_DEBUG) || defined(DEBUG)
- #if defined(_MSC_VER)
- SymSetOptions(SYMOPT_DEFERRED_LOADS | SYMOPT_INCLUDE_32BIT_MODULES);
-@@ -187,8 +181,6 @@ static void dumpBacktrace(size_t frames)
-
- CEGUI_UNUSED(frames);
-
--#endif
--
- #endif
- }
-
---
-2.26.2
-
diff --git a/dev-games/cegui/files/cegui-0.8.7-python3.patch b/dev-games/cegui/files/cegui-0.8.7-python3.patch
deleted file mode 100644
index 354f8cc65c8c..000000000000
--- a/dev-games/cegui/files/cegui-0.8.7-python3.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From b53f162767bd18aa7dfebe322a7af65593c753f5 Mon Sep 17 00:00:00 2001
-From: ATAGOYAMA Tanuki <s172262@yahoo.co.jp>
-Date: Tue, 21 Nov 2017 20:51:36 +0900
-Subject: [PATCH] cegui/src/ScriptModules/Python/binding/CMakeLists.txt: fix
- cmake error
-
----
- cegui/src/ScriptModules/Python/bindings/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt b/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt
-index 758788c67..5cc9d5620 100644
---- a/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt
-+++ b/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt
-@@ -1,5 +1,5 @@
- execute_process(
-- COMMAND ${PYTHON_EXECUTABLE} -c "import distutils.sysconfig; print distutils.sysconfig.get_python_lib(plat_specific=True, prefix=\"\")"
-+ COMMAND ${PYTHON_EXECUTABLE} -c "import distutils.sysconfig; print (distutils.sysconfig.get_python_lib(plat_specific=True, prefix=\"\"))"
- OUTPUT_VARIABLE CEGUI_PYTHON_INSTALL_DIR
- OUTPUT_STRIP_TRAILING_WHITESPACE
- )
diff --git a/dev-games/cegui/metadata.xml b/dev-games/cegui/metadata.xml
deleted file mode 100644
index 54754945469c..000000000000
--- a/dev-games/cegui/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <use>
- <flag name="devil">Build the DevIL based ImageCodec module</flag>
- <flag name="freeimage">Build the FreeImage based ImageCodec module</flag>
- <flag name="irrlicht">Enable the Irrlicht renderer</flag>
- <flag name="ogre">Enable the OGRE renderer</flag>
- <flag name="tinyxml">Enable the Tiny XML parser module</flag>
- <flag name="xerces-c">Enable the Xerces-C++ XML parser module</flag>
- <flag name="zip">Enable the Minizip resource provider</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">crayzedsgui</remote-id>
- </upstream>
-</pkgmetadata>