summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-10-17 15:57:34 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2020-10-17 15:58:04 +0200
commitb3ed56bd4d8ab75b0ab3c7021bfc42d18675f9e7 (patch)
treea3bd0ad91e3a826b5ac453836fe57670690ad14d /dev-games
parentmail-client/thunderbird-bin: bump to v78.3.3 (diff)
downloadgentoo-b3ed56bd4d8ab75b0ab3c7021bfc42d18675f9e7.tar.gz
gentoo-b3ed56bd4d8ab75b0ab3c7021bfc42d18675f9e7.tar.bz2
gentoo-b3ed56bd4d8ab75b0ab3c7021bfc42d18675f9e7.zip
dev-games/simgear: do not assume libc++ is used for clang
Closes: https://bugs.gentoo.org/735854 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/files/simgear-2020.1.2-do-not-assume-libc++-clang.patch12
-rw-r--r--dev-games/simgear/simgear-2020.1.2.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-games/simgear/files/simgear-2020.1.2-do-not-assume-libc++-clang.patch b/dev-games/simgear/files/simgear-2020.1.2-do-not-assume-libc++-clang.patch
new file mode 100644
index 000000000000..3ff70aeebdc5
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2020.1.2-do-not-assume-libc++-clang.patch
@@ -0,0 +1,12 @@
+diff -ruN simgear-2020.1.2/CMakeLists.txt simgear-my/CMakeLists.txt
+--- simgear-2020.1.2/CMakeLists.txt 2020-05-24 17:13:35.000000000 +0200
++++ simgear-my/CMakeLists.txt 2020-10-17 15:48:58.375116913 +0200
+@@ -442,8 +442,6 @@
+ set(WARNING_FLAGS_CXX "-Wall -fPIC -Wno-overloaded-virtual -Wno-redeclared-class-member")
+ set(WARNING_FLAGS_C "-Wall -fPIC")
+ set(CMAKE_XCODE_ATTRIBUTE_CLANG_CXX_LIBRARY "libc++")
+- # fix Boost compilation :(
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
+
+ # override CMake default RelWithDebInfo flags.
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O3 -g -DNDEBUG")
diff --git a/dev-games/simgear/simgear-2020.1.2.ebuild b/dev-games/simgear/simgear-2020.1.2.ebuild
index 2408384dadbc..c8ea38b80be6 100644
--- a/dev-games/simgear/simgear-2020.1.2.ebuild
+++ b/dev-games/simgear/simgear-2020.1.2.ebuild
@@ -36,6 +36,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2019.1.1-gdal3.patch"
"${FILESDIR}/${P}-boost.patch"
+ "${FILESDIR}/${PN}-2020.1.2-do-not-assume-libc++-clang.patch"
)
pkg_pretend() {