summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-15 22:59:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-16 02:05:34 -0400
commitc66d88873ab3c92f100350575d73fae1eaba7d3b (patch)
tree650f209b64e58b2d971f1e0be174a09b148c425c /dev-games
parentxfce-extra/xfce4-pulseaudio-plugin: Bump to 0.4.5 (diff)
downloadgentoo-c66d88873ab3c92f100350575d73fae1eaba7d3b.tar.gz
gentoo-c66d88873ab3c92f100350575d73fae1eaba7d3b.tar.bz2
gentoo-c66d88873ab3c92f100350575d73fae1eaba7d3b.zip
dev-games/godot: add 4.0_beta1, keyworded
Was already planning to keyword once it's out of alpha with the first beta given realistically new projects should be started on 4 even if beta (migration from 3 is non-trivial). Reminder that it's slotted and 3 is very much still supported, so godot:3 can be added to world file for working on or running older projects. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/Manifest1
-rw-r--r--dev-games/godot/godot-4.0_beta1.ebuild256
2 files changed, 257 insertions, 0 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 4b162b1ad98f..a10e7de1e3a7 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,3 +1,4 @@
DIST godot-3.5-stable.tar.xz 24044340 BLAKE2B 9d77ecdfa6bd90065fff26c2334f13c32bbbc4b26aad111b5aab2563d1e4782457ea6cf2115f1a809e0d8aac3d3ee9a138ad224998068983ad36e54a577d89c3 SHA512 23785e39ccc7e1406c97ee33b5e90f7f397aa907d79d72ed08ea3f4b7e68788030a1bcdd07c9f782a21ee3a84636a2cea47a57dcfc94c24e327fa210ae0515b0
DIST godot-4.0-alpha16.tar.xz 31012408 BLAKE2B 6492953945e3f2f77da5dcf042d791dd2dc903e65b787704c8053d1ac61852dd3c1d8f8aa0a383f1c86495c863d1f15f6d5e77e6ecadda7ff87ae7c87bdce810 SHA512 56e87c7a02abf9dee15e89be829046b9335a7c01b7bd3bb38d71b3fe1f262f6e923741c47c2d96b2633b9a16f71882ec87aaf06bad42d4bdf7a429ff2db0b4b1
DIST godot-4.0-alpha17.tar.xz 31106496 BLAKE2B 4ac31703dac68a0e204e095c421015632ca8fbbb3dc379cd937f1375ab4c830c89ddeca8f9fe5cb080ea82616c786df4c1bf0d0fa7f52e552d750f1bb2d56a08 SHA512 9840391fbcbaa88b73b3fe8b133f0537c1f2a12eedb8bc0931922cf724a1d815516b7566cfac98787706a6eca6e2a35ecea3d9d14266501c8612dcb929a975d1
+DIST godot-4.0-beta1.tar.xz 31113892 BLAKE2B b7adc96ea9d19b962833bb3244f464151a08befb1301dbd147f421c8fb649dcb645656e0982aebaec695988c29e763f52456fa7e23a52b64cfddf39866f2c0af SHA512 86babe6bcd960f3e911b309de39145535f8755ffb64ba024315eab253803d78049020a6f7362318b9e29ba27527e479fba95a20db686ec854ba0a377a276d467
diff --git a/dev-games/godot/godot-4.0_beta1.ebuild b/dev-games/godot/godot-4.0_beta1.ebuild
new file mode 100644
index 000000000000..2c88cf57aa9d
--- /dev/null
+++ b/dev-games/godot/godot-4.0_beta1.ebuild
@@ -0,0 +1,256 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 desktop python-any-r1 scons-utils toolchain-funcs xdg
+
+MY_P="${PN}-$(ver_rs 2 -)"
+
+DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
+HOMEPAGE="https://godotengine.org/"
+SRC_URI="https://downloads.tuxfamily.org/godotengine/$(ver_rs 2 /)/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="
+ MIT
+ Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
+ gui? ( CC-BY-4.0 ) tools? ( OFL-1.1 )"
+SLOT="4"
+KEYWORDS="~amd64"
+# Enable roughly same as upstream by default so it works as expected,
+# except raycast (tools-only heavy dependency), and deprecated.
+IUSE="
+ +dbus debug deprecated +fontconfig +gui pulseaudio raycast
+ +runner speech test +theora +tools +udev +upnp +webp"
+RESTRICT="!test? ( test ) !tools? ( test ) !webp? ( test )"
+
+# dlopen: alsa-lib,dbus,fontconfig,pulseaudio,speech-dispatcher,udev
+RDEPEND="
+ app-arch/zstd:=
+ dev-games/recastnavigation:=
+ dev-libs/icu:=
+ dev-libs/libpcre2:=[pcre32]
+ media-libs/freetype[brotli,harfbuzz]
+ media-libs/harfbuzz:=[icu]
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libvorbis
+ <net-libs/mbedtls-3:=
+ net-libs/wslay
+ sys-libs/zlib:=
+ fontconfig? ( media-libs/fontconfig )
+ gui? (
+ dev-util/glslang
+ media-libs/alsa-lib
+ media-libs/libglvnd[X]
+ media-libs/vulkan-loader[X]
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ dbus? ( sys-apps/dbus )
+ pulseaudio? ( media-libs/libpulse )
+ tools? ( raycast? ( media-libs/embree:3 ) )
+ udev? ( virtual/udev )
+ )
+ speech? ( app-accessibility/speech-dispatcher )
+ theora? ( media-libs/libtheora )
+ tools? ( app-misc/ca-certificates )
+ upnp? ( net-libs/miniupnpc:= )
+ webp? ( media-libs/libwebp:= )"
+DEPEND="
+ ${RDEPEND}
+ gui? (
+ dev-util/vulkan-headers
+ x11-base/xorg-proto
+ )
+ tools? ( test? ( dev-cpp/doctest ) )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0-musl.patch
+ "${FILESDIR}"/${PN}-4.0_alpha14-scons.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
+ sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
+ sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
+ -i misc/dist/linux/org.godotengine.Godot.desktop || die
+
+ sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/linuxbsd/detect.py || die
+
+ # use of builtin_ switches can be messy (see below), delete to be sure
+ local unbundle=(
+ doctest embree freetype glslang graphite harfbuzz icu4c libogg libpng
+ libtheora libvorbis libwebp mbedtls miniupnpc pcre2 recastnavigation
+ volk vulkan/include wslay zlib zstd
+ # certs: unused by generated header, but scons panics if not found
+ )
+ rm -r "${unbundle[@]/#/thirdparty/}" || die
+
+ # do symlinks to avoid too much patching with hardcoded header paths
+ mkdir thirdparty/lib{vorbis,ogg} || die
+ ln -s "${ESYSROOT}"/usr/include thirdparty/zstd || die
+ ln -s "${ESYSROOT}"/usr/include/doctest thirdparty/ || die
+ ln -s "${ESYSROOT}"/usr/include/ogg thirdparty/libogg/ || die
+ ln -s "${ESYSROOT}"/usr/include/vorbis thirdparty/libvorbis/ || die
+}
+
+src_compile() {
+ local -x GODOT_VERSION_STATUS=$(ver_cut 3-4) # for dev versions only
+ local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
+
+ local esconsargs=(
+ AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+
+ progress=no
+ verbose=yes
+
+ deprecated=$(usex deprecated)
+ #execinfo=$(usex !elibc_glibc) # libexecinfo is not packaged
+ fontconfig=$(usex fontconfig)
+ minizip=yes # uses a modified bundled copy
+ opengl3=$(usex gui)
+ pulseaudio=$(usex gui $(usex pulseaudio))
+ speechd=$(usex speech)
+ udev=$(usex gui $(usex udev))
+ use_dbus=$(usex gui $(usex dbus))
+ use_volk=no # unnecessary when linking directly to libvulkan
+ vulkan=$(usex gui) # hard-required and favored by upstream over gles3
+ x11=$(usex gui)
+
+ system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+
+ # platform/*/detect.py uses builtin_* switches to check if need
+ # to link with system libraries, but ignores whether the dep is
+ # actually used, so "enable" deleted builtins on disabled deps
+ builtin_certs=no
+ builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
+ builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
+ builtin_freetype=no
+ builtin_glslang=$(usex !gui)
+ builtin_graphite=no
+ builtin_harfbuzz=no
+ builtin_icu=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libtheora=$(usex !theora)
+ builtin_libvorbis=no
+ builtin_libwebp=$(usex !webp)
+ builtin_mbedtls=no
+ builtin_miniupnpc=$(usex !upnp)
+ builtin_msdfgen=yes # not wired for unbundling nor packaged
+ builtin_pcre2=no
+ builtin_recast=no
+ builtin_rvo2=yes # bundled copy has godot-specific changes
+ builtin_squish=yes # ^ likewise, may not be safe to unbundle
+ builtin_wslay=no
+ builtin_xatlas=yes # not wired for unbundling nor packaged
+ builtin_zlib=no
+ builtin_zstd=no
+ # also bundled but lacking a builtin_* switch:
+ # amd-fsr, basis_universal, cvtt, etcpak, fonts, glad,
+ # jpeg-compressor, meshoptimizer, minimp3, minizip (patched to
+ # seek in archives), noise, oidn, openxr, spirv-reflect, thorvg,
+ # tinyexr, vhacd, vulkan (minus include/) and the misc directory.
+
+ # modules with optional dependencies, "possible" to disable more but
+ # gets messy and breaks all sorts of features (expected enabled)
+ module_glslang_enabled=$(usex gui)
+ module_gridmap_enabled=$(usex deprecated) # fails without deprecated
+ module_mono_enabled=no # unhandled
+ # note raycast is only enabled on amd64+arm64, see raycast/config.py
+ module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
+ module_theora_enabled=$(usex theora)
+ module_upnp_enabled=$(usex upnp)
+ module_webp_enabled=$(usex webp)
+
+ # let *FLAGS handle these, e.g. can pass -flto as-is
+ debug_symbols=no
+ lto=none
+ optimize=none
+ use_static_cpp=no
+ )
+
+ if use runner && use tools; then
+ # build alternate faster + ~60% smaller binary for running
+ # games or servers without game development debug paths
+ escons extra_suffix=runner target=release tools=no "${esconsargs[@]}"
+ fi
+
+ esconsargs+=(
+ # debug: debug for godot itself
+ # release_debug: debug for game development
+ # release: no debugging paths, only available with tools=no
+ target=$(usex debug{,} $(usex tools release_debug release))
+ tools=$(usex tools)
+
+ # harmless but note this bakes in --test in the final binary
+ tests=$(usex tools $(usex test))
+ )
+
+ escons extra_suffix=main "${esconsargs[@]}"
+}
+
+src_test() {
+ xdg_environment_reset
+ bin/godot*.main --headless --test || die
+}
+
+src_install() {
+ local s=godot${SLOT}
+
+ newbin bin/godot*.main ${s}
+ if use runner && use tools; then
+ newbin bin/godot*.runner ${s}-runner
+ else
+ # always available, revdeps shouldn't depend on [runner]
+ dosym ${s} /usr/bin/${s}-runner
+ fi
+
+ newman misc/dist/linux/godot.6 ${s}.6
+ dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
+
+ if use gui; then
+ newicon icon.svg ${s}.svg
+ newmenu misc/dist/linux/org.godotengine.Godot.desktop \
+ org.godotengine.${s^}.desktop
+
+ insinto /usr/share/metainfo
+ newins misc/dist/linux/org.godotengine.Godot.appdata.xml \
+ org.godotengine.${s^}.appdata.xml
+
+ insinto /usr/share/mime/application
+ newins misc/dist/linux/org.godotengine.Godot.xml \
+ org.godotengine.${s^}.xml
+ fi
+
+ newbashcomp misc/dist/shell/godot.bash-completion ${s}
+ bashcomp_alias ${s}{,-runner}
+
+ insinto /usr/share/fish/vendor_completions.d
+ newins misc/dist/shell/godot.fish ${s}.fish
+ dosym ${s}.fish /usr/share/fish/vendor_completions.d/${s}-runner.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins misc/dist/shell/_godot.zsh-completion _${s}
+ dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]] && has_version ${CATEGORY}/${PN}:3; then
+ elog
+ elog "Remember to make backups before opening any Godot <=3.x projects in Godot 4."
+ elog "Automated migration is only partial, and it would be difficult to revert."
+ fi
+}