summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:19:25 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:47 +0100
commitd41b7a911f03d5fc2cfa33653aaafb0007fe0a4b (patch)
treea45f1eec511086f9db3162d160618cdfec41e1d2 /dev-games
parentapp-text/tokyodystopia: fix DeprecatedInsinto, clean up patches (diff)
downloadgentoo-d41b7a911f03d5fc2cfa33653aaafb0007fe0a4b.tar.gz
gentoo-d41b7a911f03d5fc2cfa33653aaafb0007fe0a4b.tar.bz2
gentoo-d41b7a911f03d5fc2cfa33653aaafb0007fe0a4b.zip
dev-games/clanlib: tidy up patches, respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/clanlib-2.3.7-r1.ebuild6
-rw-r--r--dev-games/clanlib/clanlib-4.0.0.ebuild7
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch2
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch15
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch4
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-llvm.patch8
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch5
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch2
-rw-r--r--dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch8
9 files changed, 21 insertions, 36 deletions
diff --git a/dev-games/clanlib/clanlib-2.3.7-r1.ebuild b/dev-games/clanlib/clanlib-2.3.7-r1.ebuild
index 58b7cf899bfe..de31fc373c2b 100644
--- a/dev-games/clanlib/clanlib-2.3.7-r1.ebuild
+++ b/dev-games/clanlib/clanlib-2.3.7-r1.ebuild
@@ -3,10 +3,10 @@
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
MY_P=ClanLib-${PV}
-DESCRIPTION="multi-platform game development library"
+DESCRIPTION="Multi-platform game development library"
HOMEPAGE="http://www.clanlib.org/"
SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
S="${WORKDIR}"/${MY_P}
@@ -83,6 +83,8 @@ src_configure() {
|| use mikmod \
|| myeconfargs+=( --disable-clanSound )
+ tc-export PKG_CONFIG
+
econf "${myeconfargs[@]}"
}
diff --git a/dev-games/clanlib/clanlib-4.0.0.ebuild b/dev-games/clanlib/clanlib-4.0.0.ebuild
index cc7115a38348..26eea39ba088 100644
--- a/dev-games/clanlib/clanlib-4.0.0.ebuild
+++ b/dev-games/clanlib/clanlib-4.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools toolchain-funcs
MY_PN=ClanLib
@@ -60,6 +60,9 @@ src_configure() {
$(use_enable ipv6 getaddr)
$(use_enable static-libs static)
)
+
+ tc-export PKG_CONFIG
+
econf "${myeconfargs[@]}"
}
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch b/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch
index 18752b9e0fbd..f5a35763c48d 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch
@@ -1,5 +1,3 @@
-diff --git a/Documentation/Utilities/webbuilder.pl.in b/Documentation/Utilities/webbuilder.pl.in
-index ea9de63..c000432 100644
--- a/Documentation/Utilities/webbuilder.pl.in
+++ b/Documentation/Utilities/webbuilder.pl.in
@@ -68,11 +68,7 @@ sub convert
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
index ddf5a170b027..0851074bddcb 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
@@ -1,6 +1,5 @@
-diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp
---- ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp 2009-08-01 18:15:44.000000000 +0200
-+++ ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp 2009-08-01 18:08:55.000000000 +0200
+--- a/Sources/GL/canvas_opengl.cpp
++++ b/Sources/GL/canvas_opengl.cpp
@@ -48,6 +48,7 @@
#include "graphic_context_opengl.h"
#include "surface_target_opengl.h"
@@ -9,9 +8,8 @@ diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/
/////////////////////////////////////////////////////////////////////////////
// CL_Canvas_OpenGL construction:
-diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp
---- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:17:25.000000000 +0200
-+++ ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:11:23.000000000 +0200
+--- a/Sources/GL/GLX/input_device_linuxevent.cpp
++++ b/Sources/GL/GLX/input_device_linuxevent.cpp
@@ -35,6 +35,7 @@
#include <iostream>
#include <errno.h>
@@ -20,9 +18,8 @@ diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-
#include "API/Core/System/error.h"
#include "API/Core/System/clanstring.h"
-diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp
---- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:17:41.000000000 +0200
-+++ ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:12:56.000000000 +0200
+--- a/Sources/GL/GLX/input_device_xinput.cpp
++++ b/Sources/GL/GLX/input_device_xinput.cpp
@@ -29,6 +29,7 @@
#include <iostream>
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
index 19ebab6fd07d..db9b90ff9d23 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
@@ -1,5 +1,5 @@
---- ./Sources/Core/IOData/Generic/inputsource_file.cpp.orig 2012-12-30 01:49:01.698950614 +0400
-+++ ./Sources/Core/IOData/Generic/inputsource_file.cpp 2012-12-30 01:49:27.714977456 +0400
+--- a/Sources/Core/IOData/Generic/inputsource_file.cpp
++++ b/Sources/Core/IOData/Generic/inputsource_file.cpp
@@ -32,6 +32,7 @@
#ifdef WIN32
#include <direct.h>
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch b/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch
index b1455149a321..63f9a1415423 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-llvm.patch
@@ -1,5 +1,3 @@
-diff --git a/Sources/Display/graphic_context.cpp b/Sources/Display/graphic_context.cpp
-index 42545ea..52220e2 100644
--- a/Sources/Display/graphic_context.cpp
+++ b/Sources/Display/graphic_context.cpp
@@ -237,18 +237,18 @@ void CL_GraphicContext::fill_triangle(
@@ -33,8 +31,6 @@ index 42545ea..52220e2 100644
params.count = 1;
params.vertices = vertice_array;
-diff --git a/Sources/GL/graphic_context_opengl.cpp b/Sources/GL/graphic_context_opengl.cpp
-index 78bc87d..68da072 100644
--- a/Sources/GL/graphic_context_opengl.cpp
+++ b/Sources/GL/graphic_context_opengl.cpp
@@ -355,8 +355,8 @@ void CL_GraphicContext_OpenGL::draw_quad(const CL_Quad &quad, const CL_Color &co
@@ -59,8 +55,6 @@ index 78bc87d..68da072 100644
int tx[4] = { quad.x1, quad.x2, quad.x3, quad.x4 };
int ty[4] = { quad.y1, quad.y2, quad.y3, quad.y4 };
-diff --git a/Sources/SDL/graphic_context_sdl.cpp b/Sources/SDL/graphic_context_sdl.cpp
-index 8093e03..c15b399 100644
--- a/Sources/SDL/graphic_context_sdl.cpp
+++ b/Sources/SDL/graphic_context_sdl.cpp
@@ -410,7 +410,7 @@ void CL_GraphicContext_SDL::update_cliprect()
@@ -72,8 +66,6 @@ index 8093e03..c15b399 100644
SDL_SetClipRect(SDL_GetVideoSurface(),&crect);
}
}
-diff --git a/Sources/SDL/surface_sdl.cpp b/Sources/SDL/surface_sdl.cpp
-index ff6e36f..532db84 100644
--- a/Sources/SDL/surface_sdl.cpp
+++ b/Sources/SDL/surface_sdl.cpp
@@ -259,13 +259,13 @@ void CL_Surface_SDL::draw(
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
index 4a9a4a08582b..b9a891e99a7a 100644
--- a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
+++ b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
@@ -8,9 +8,8 @@ rather than a debug version is built (-DNDEBUG).
This patch adds the missing declaration, thus make the
file compile with or without -DNDEBUG.
-diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
---- a/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
-+++ b/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
+--- a/Sources/Core/System/Unix/init_linux.cpp
++++ b/Sources/Core/System/Unix/init_linux.cpp
@@ -52,6 +52,7 @@
_begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch b/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
index d10a3b0085ad..cadb3b90b530 100644
--- a/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
+++ b/dev-games/clanlib/files/clanlib-2.3.7-freetype_pkgconfig.patch
@@ -7,7 +7,7 @@ https://bugs.gentoo.org/764902
CLANLIB_CHECK_LIB(png, [`cat $srcdir/Setup/Tests/png.cpp`], clanDisplay, [ *** Cannot find png (See http://www.libpng.org ) (Try libpng12-dev or better) ], [-lz -lpng])
CLANLIB_CHECK_LIB(jpeg, [`cat $srcdir/Setup/Tests/jpeg.cpp`], clanDisplay, [ *** Cannot find jpeg (See http://www.ijg.org ) (Try libjpeg62-dev or better) ], [ -ljpeg])
- CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`freetype-config --libs` ], [ `freetype-config --cflags`])
-+ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`pkg-config --libs freetype2` ], [ `pkg-config --cflags freetype2`])
++ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`${PKG_CONFIG} --libs freetype2` ], [ `${PKG_CONFIG} --cflags freetype2`])
dnl Optional linux/joystick.h
AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
diff --git a/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch b/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch
index 34759a8d89d9..1dbb11d07c1d 100644
--- a/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch
+++ b/dev-games/clanlib/files/clanlib-4.0.0-freetype_pkgconfig.patch
@@ -5,12 +5,6 @@ Subject: [PATCH] Use pkg-config to find freetype.
As of freetype-2.9.1 the freetype-config file no longer gets installed
by default.
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 6b9def916..c97e959f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,7 +307,7 @@ echo ""
@@ -18,7 +12,7 @@ index 6b9def916..c97e959f7 100644
echo "Checking for clanDisplay stuff"
echo "=============================="
- CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`freetype-config --libs` ], [ `freetype-config --cflags`])
-+ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`pkg-config --libs freetype2` ], [ `pkg-config --cflags freetype2`])
++ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`${PKG_CONFIG} --libs freetype2` ], [ `${PKG_CONFIG} --cflags freetype2`])
dnl Optional linux/joystick.h
AC_CHECK_HEADERS(linux/joystick.h, has_linux_joystick=yes)