summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-12 19:24:07 +0000
committerSam James <sam@gentoo.org>2021-03-12 19:24:07 +0000
commitdb01ac92b2bd0d5415463fd8ed769dda67cb05d7 (patch)
tree1210306a500b0a67975de9e19f214ad578aaa5b7 /dev-games
parentdev-games/clanlib: Stabilize 2.3.7-r1 x86, #772824 (diff)
downloadgentoo-db01ac92b2bd0d5415463fd8ed769dda67cb05d7.tar.gz
gentoo-db01ac92b2bd0d5415463fd8ed769dda67cb05d7.tar.bz2
gentoo-db01ac92b2bd0d5415463fd8ed769dda67cb05d7.zip
dev-games/clanlib: drop 0.8.1, 2.3.7
Bug: https://bugs.gentoo.org/772824 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/clanlib-0.8.1.ebuild76
-rw-r--r--dev-games/clanlib/clanlib-2.3.7.ebuild98
2 files changed, 0 insertions, 174 deletions
diff --git a/dev-games/clanlib/clanlib-0.8.1.ebuild b/dev-games/clanlib/clanlib-0.8.1.ebuild
deleted file mode 100644
index 7aa5d3df56ef..000000000000
--- a/dev-games/clanlib/clanlib-0.8.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit flag-o-matic eutils ltprune
-
-DESCRIPTION="multi-platform game development library"
-HOMEPAGE="http://www.clanlib.org/"
-SRC_URI="http://clanlib.org/download/releases-${PV:0:3}/ClanLib-${PV}.tgz"
-
-LICENSE="ZLIB"
-SLOT="0.8"
-KEYWORDS="amd64 x86" #not big endian safe #82779
-IUSE="doc ipv6 mikmod opengl sdl static-libs vorbis"
-
-# opengl keyword does not drop the GL/GLU requirement.
-# Autoconf files need to be fixed
-RDEPEND="media-libs/libpng:0
- virtual/jpeg:0
- virtual/glu
- virtual/opengl
- sdl? (
- media-libs/libsdl[X]
- media-libs/sdl-gfx
- )
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- media-libs/alsa-lib
- mikmod? ( media-libs/libmikmod )
- vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-S=${WORKDIR}/ClanLib-${PV}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-ndebug.patch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-gcc47.patch \
- "${FILESDIR}"/${P}-gcc6.patch \
- "${FILESDIR}"/${P}-libpng15.patch
-}
-
-src_configure() {
- #clanSound only controls mikmod/vorbis so there's
- # no need to pass --{en,dis}able-clanSound ...
- #clanDisplay only controls X, SDL, OpenGL plugins
- # so no need to pass --{en,dis}able-clanDisplay
- # also same reason why we don't have to use clanGUI
- econf \
- --enable-dyn \
- --enable-clanNetwork \
- $(use_enable x86 asm386) \
- $(use_enable doc docs) \
- $(use_enable opengl clanGL) \
- $(use_enable sdl clanSDL) \
- $(use_enable vorbis clanVorbis) \
- $(use_enable mikmod clanMikMod) \
- $(use_enable ipv6 getaddr) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- DOCS="CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux" \
- default
- if use doc ; then
- dodir /usr/share/doc/${PF}/html
- mv "${D}"/usr/share/doc/clanlib/* "${D}"/usr/share/doc/${PF}/html/ || die
- rm -rf "${D}"/usr/share/doc/clanlib
- cp -r Examples Resources "${D}"/usr/share/doc/${PF}/ || die
- fi
- prune_libtool_files
-}
diff --git a/dev-games/clanlib/clanlib-2.3.7.ebuild b/dev-games/clanlib/clanlib-2.3.7.ebuild
deleted file mode 100644
index 08584b0cf5d6..000000000000
--- a/dev-games/clanlib/clanlib-2.3.7.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit flag-o-matic eutils autotools-utils
-
-MY_P=ClanLib-${PV}
-
-DESCRIPTION="multi-platform game development library"
-HOMEPAGE="http://www.clanlib.org/"
-SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
-
-LICENSE="ZLIB"
-SLOT="2.3"
-KEYWORDS="amd64 x86" #not big endian safe #82779
-IUSE="doc ipv6 mikmod opengl sound sqlite cpu_flags_x86_sse2 static-libs vorbis X"
-REQUIRED_USE="opengl? ( X )"
-
-RDEPEND="sys-libs/zlib
- X? (
- media-libs/libpng:0
- virtual/jpeg:0
- media-libs/freetype
- media-libs/fontconfig
- opengl? ( virtual/opengl )
- app-arch/bzip2
- x11-libs/libX11
- )
- sqlite? ( dev-db/sqlite:3 )
- sound? ( media-libs/alsa-lib )
- mikmod? (
- media-libs/libmikmod
- media-libs/alsa-lib
- )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- media-libs/alsa-lib
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen dev-lang/perl )"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-autotools.patch
- "${FILESDIR}"/${P}-doc.patch
- "${FILESDIR}"/${P}-freetype_pkgconfig.patch #764902
-)
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-DOCS=(
- CODING_STYLE
- CREDITS
- PATCHES
- README
-)
-
-src_prepare() {
- autotools-utils_src_prepare
- ln -sf ../../../Sources/API Documentation/Utilities/ReferenceDocs/ClanLib
-}
-
-src_configure() {
- myeconfargs=(
- $(use_enable doc docs)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable opengl clanGL)
- $(use_enable opengl clanGL1)
- $(use_enable opengl clanGUI)
- $(use_enable X clanDisplay)
- $(use_enable vorbis clanVorbis)
- $(use_enable mikmod clanMikMod)
- $(use_enable sqlite clanSqlite)
- $(use_enable ipv6 getaddr)
- )
- use sound \
- || use vorbis \
- || use mikmod \
- || myeconfargs+=( --disable-clanSound )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile html
-}
-
-# html files are keeped in a directory that is dependent on the SLOT
-# so to keep eventual bookmarks to the doc from version to version
-src_install() {
- autotools-utils_src_install
- if use doc ; then
- emake DESTDIR="${D}" install-html
- dodoc -r Examples Resources
- fi
-}