summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 03:25:02 +0000
committerSam James <sam@gentoo.org>2021-04-19 04:30:48 +0000
commite86a7a5123f86e1d3cb2358f0a36343d9910c150 (patch)
tree871ac9e98d4d0b69a4da9b16a39cd850e77042e6 /dev-games
parentdev-games/wfmath: commit bashisms patch (diff)
downloadgentoo-e86a7a5123f86e1d3cb2358f0a36343d9910c150.tar.gz
gentoo-e86a7a5123f86e1d3cb2358f0a36343d9910c150.tar.bz2
gentoo-e86a7a5123f86e1d3cb2358f0a36343d9910c150.zip
dev-games/poker-eval: port to EAPI 7, ltprune--, drop static-libs
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/poker-eval/poker-eval-138.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-games/poker-eval/poker-eval-138.0.ebuild b/dev-games/poker-eval/poker-eval-138.0.ebuild
index c34ff4181418..415cd26152e0 100644
--- a/dev-games/poker-eval/poker-eval-138.0.ebuild
+++ b/dev-games/poker-eval/poker-eval-138.0.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit ltprune
+EAPI=7
DESCRIPTION="A fast C library for evaluating poker hands"
HOMEPAGE="http://gna.org/projects/pokersource/"
@@ -11,16 +10,16 @@ SRC_URI="http://download.gna.org/pokersource/sources/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO WHATS-HERE )
src_configure() {
econf \
--without-ccache \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README TODO WHATS-HERE" \
- default
- prune_libtool_files
+ default
+ find "${ED}" -name '*.la' -delete || die
}