summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-04-19 09:30:45 +0200
committerSam James <sam@gentoo.org>2023-04-26 05:02:51 +0100
commitf86aa8b4b62bd049186d15203cf0d8afad956135 (patch)
treea2a53fe5ce6e07bd4b0c5894481396f415face16 /dev-games
parentnet-news/liferea: add python 3.11 support to 1.12.10 (diff)
downloadgentoo-f86aa8b4b62bd049186d15203cf0d8afad956135.tar.gz
gentoo-f86aa8b4b62bd049186d15203cf0d8afad956135.tar.bz2
gentoo-f86aa8b4b62bd049186d15203cf0d8afad956135.zip
dev-games/simgear: Version bump to 2020.3.18
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/Manifest1
-rw-r--r--dev-games/simgear/simgear-2020.3.18.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-games/simgear/Manifest b/dev-games/simgear/Manifest
index 5d85924f4846..73f90891b4f1 100644
--- a/dev-games/simgear/Manifest
+++ b/dev-games/simgear/Manifest
@@ -1 +1,2 @@
DIST simgear-2020.3.17.tar.bz2 1418448 BLAKE2B d3541c31fcf8571ba73d7fe3952c6d30146f33ffe776962670f9607d5d8e02dc24095e35933887aed3b1dcddb4d6b94e19e5317364f651d69d787afde45a30a5 SHA512 019ea59af6679c4a899a044c38f60c21c15469528d1bab8b0d4388810b045af7812c3c561eee7190a5464adae0c14d16d528f08c69b37291d4e1b35665cbefce
+DIST simgear-2020.3.18.tar.bz2 1423264 BLAKE2B 5013d25819713e1a3de1d8e42aba68bbc70c60ebad45f0d3475392188f5fc9db7266536ef365ab60a183a3998edf0941d093ee1ee50a9293b32bcfafe5da57d0 SHA512 8101ea073e3e701759b4cea77ebf376897d7e02d4f9ebf0248dcba7dc9186f11cfd7921b2ed8f77e0168a851fff0904107881087ce4e12597c1fdc63b34eef25
diff --git a/dev-games/simgear/simgear-2020.3.18.ebuild b/dev-games/simgear/simgear-2020.3.18.ebuild
new file mode 100644
index 000000000000..d6d0a2a4d7b7
--- /dev/null
+++ b/dev-games/simgear/simgear-2020.3.18.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="https://www.flightgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="cpu_flags_x86_sse2 +dns debug gdal openmp subversion test"
+RESTRICT="!test? ( test )"
+
+# TODO aeonwave
+COMMON_DEPEND="
+ app-arch/xz-utils
+ dev-libs/expat
+ dev-games/openscenegraph
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/opengl
+ dns? ( net-libs/udns )
+ gdal? ( sci-libs/gdal:= )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2019.1.1-gdal3.patch"
+ "${FILESDIR}/${PN}-2020.1.2-do-not-assume-libc++-clang.patch"
+ "${FILESDIR}/${PN}-2020.3.17-boost-1.81.patch"
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DNS=$(usex dns)
+ -DENABLE_GDAL=$(usex gdal)
+ -DENABLE_OPENMP=$(usex openmp)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SIMD=$(usex cpu_flags_x86_sse2)
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ -DSYSTEM_UDNS=ON
+ -DUSE_AEONWAVE=OFF
+ -DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
+ )
+ cmake_src_configure
+}