summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Perlov <perlovka@gmail.com>2018-10-07 22:44:29 +0300
committerZac Medico <zmedico@gentoo.org>2018-10-07 14:35:41 -0700
commit75e230b730e5e942170a0d9fe6403c1f839be180 (patch)
treeece223d6a22994ebf37bbe6b42c1cac40d8c97b9 /dev-go/go-protobuf/go-protobuf-1.2.0.ebuild
parentmedia-libs/x265-2.8: ppc64 stable, bug 666486 (diff)
downloadgentoo-75e230b730e5e942170a0d9fe6403c1f839be180.tar.gz
gentoo-75e230b730e5e942170a0d9fe6403c1f839be180.tar.bz2
gentoo-75e230b730e5e942170a0d9fe6403c1f839be180.zip
dev-go/go-protobuf: version bump to 1.2.0
Closes: https://github.com/gentoo/gentoo/pull/10100 Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Michael Perlov <perlovka@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-go/go-protobuf/go-protobuf-1.2.0.ebuild')
-rw-r--r--dev-go/go-protobuf/go-protobuf-1.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-go/go-protobuf/go-protobuf-1.2.0.ebuild b/dev-go/go-protobuf/go-protobuf-1.2.0.ebuild
new file mode 100644
index 000000000000..00647dff8767
--- /dev/null
+++ b/dev-go/go-protobuf/go-protobuf-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_SRC="github.com/golang/protobuf"
+EGO_PN=${EGO_SRC}/...
+EGO_VENDOR=(
+ "google.golang.org/genproto af9cb2a35e7f169ec875002c1829c9b315cddc04 github.com/google/go-genproto"
+)
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="https://github.com/golang/protobuf"
+SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+ rm -rf "${D%/}$(get_golibdir_gopath)/src/${EGO_SRC}/vendor" || die
+
+ dobin bin/*
+}