summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-12 13:42:51 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-12 13:43:24 -0600
commit098c4725950f43736bf30c75368b0bef2b459659 (patch)
tree70fc28a9e0252a2cbe476998f4d2d6ab1c2c2376 /dev-go/golint/golint-0_pre20161114.ebuild
parentsys-kernel/aufs-sources: Bump to latest aufs, genpatches and linux release (diff)
downloadgentoo-098c4725950f43736bf30c75368b0bef2b459659.tar.gz
gentoo-098c4725950f43736bf30c75368b0bef2b459659.tar.bz2
gentoo-098c4725950f43736bf30c75368b0bef2b459659.zip
dev-go/golint: new package
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-go/golint/golint-0_pre20161114.ebuild')
-rw-r--r--dev-go/golint/golint-0_pre20161114.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-go/golint/golint-0_pre20161114.ebuild b/dev-go/golint/golint-0_pre20161114.ebuild
new file mode 100644
index 000000000000..23c9d3dee16a
--- /dev/null
+++ b/dev-go/golint/golint-0_pre20161114.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+EGO_PN="github.com/golang/lint/..."
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT=206c0f0
+ SRC_URI="https://github.com/golang/lint/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="a linter for Go"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=">=dev-lang/go-1.6
+ dev-go/go-tools"
+RDEPEND="!<dev-lang/go-1.6
+ dev-go/go-tools:="
+
+DOCS=(
+ src/github.com/golang/lint/CONTRIBUTING.md
+ src/github.com/golang/lint/README.md
+ src/github.com/golang/lint/misc
+ )
+
+ src_install() {
+ golang-build_src_install
+ einstalldocs
+ dobin bin/*
+}