summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-16 18:35:59 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-16 18:35:59 +0100
commit5dc967572dd212832fdcde3b19441b4c5b294717 (patch)
tree87071c75b9a2dc489c7579fcd8f6bed768aa9f60 /dev-go
parentdev-java/libreadline-java: treeclean (diff)
downloadgentoo-5dc967572dd212832fdcde3b19441b4c5b294717.tar.gz
gentoo-5dc967572dd212832fdcde3b19441b4c5b294717.tar.bz2
gentoo-5dc967572dd212832fdcde3b19441b4c5b294717.zip
dev-go/go-text: treeclean
Closes: https://bugs.gentoo.org/800141 Closes: https://bugs.gentoo.org/688714 Closes: https://bugs.gentoo.org/627072 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-text/Manifest1
-rw-r--r--dev-go/go-text/go-text-0.3.0.ebuild47
-rw-r--r--dev-go/go-text/go-text-9999.ebuild49
-rw-r--r--dev-go/go-text/metadata.xml10
4 files changed, 0 insertions, 107 deletions
diff --git a/dev-go/go-text/Manifest b/dev-go/go-text/Manifest
deleted file mode 100644
index 7c92c68dd7db..000000000000
--- a/dev-go/go-text/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST go-text-0.3.0.tar.gz 6102619 BLAKE2B c92e68014a8c157d76741c02acd708771d66bd3dda5b19285f5aa3e073e0fe3fccb9054744d35ea62b681ae4421bb7489238d6868f9314fb26f88e002287abe8 SHA512 bd60dfaa7d9dbfca171a3ba40b51f5663c01257cf3b12b618d35689a97ab2212d316d5716ff09681bf40b099f7e20a0e0df8cfc065699cb6a07ad1dc2e2bc189
diff --git a/dev-go/go-text/go-text-0.3.0.ebuild b/dev-go/go-text/go-text-0.3.0.ebuild
deleted file mode 100644
index c590eadea63f..000000000000
--- a/dev-go/go-text/go-text-0.3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN=golang.org/x/text/...
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go text processing support"
-HOMEPAGE="https://godoc.org/golang.org/x/text"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=">=dev-go/go-tools-0_pre20180817"
-RDEPEND=""
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #680946
- # Create an isolated golibdir in order to avoid an
- # "use of internal package not allowed" error when
- # and older version is installed.
- mkdir -p "${T}/golibdir/src/golang.org/x" || die
- ln -s "$(get_golibdir_gopath)/src/golang.org/x/tools" "${T}/golibdir/src/golang.org/x/tools" || die
- GOPATH="${S}:${T}/golibdir" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
-}
-
-src_install() {
- golang_install_pkgs
- exeopts -m0755 -p # preserve timestamps for bug 551486
- exeinto "$(go env GOROOT)/bin"
- doexe bin/*
-}
-
-src_test() {
- GOPATH="${S}:${T}/golibdir" \
- go test -v -work -x "${EGO_PN}" || die
-}
diff --git a/dev-go/go-text/go-text-9999.ebuild b/dev-go/go-text/go-text-9999.ebuild
deleted file mode 100644
index 0740869fb574..000000000000
--- a/dev-go/go-text/go-text-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_SRC=golang.org/x/text
-EGO_PN=${EGO_SRC}/...
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go text processing support"
-HOMEPAGE="https://godoc.org/golang.org/x/text"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=">=dev-go/go-tools-0_pre20180817"
-RDEPEND=""
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #680946
- # Create an isolated golibdir in order to avoid an
- # "use of internal package not allowed" error when
- # and older version is installed.
- mkdir -p "${T}/golibdir/src/golang.org/x" || die
- ln -s "$(get_golibdir_gopath)/src/golang.org/x/tools" "${T}/golibdir/src/golang.org/x/tools" || die
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
-}
-
-src_install() {
- rm -rf "${S}/src/${EGO_SRC}/.git"* || die
- golang_install_pkgs
- exeopts -m0755 -p # preserve timestamps for bug 551486
- exeinto "$(go env GOROOT)/bin"
- doexe bin/*
-}
-
-src_test() {
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
- go test -v -work -x "${EGO_PN}" || die
-}
diff --git a/dev-go/go-text/metadata.xml b/dev-go/go-text/metadata.xml
deleted file mode 100644
index 67636dcbe6a6..000000000000
--- a/dev-go/go-text/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">golang/text</remote-id>
- </upstream>
-</pkgmetadata>