summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-05-21 12:32:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-27 09:53:09 +0300
commit9554c9575d4151f5b22a9c6803cd4acf65b2ca8e (patch)
tree1b3642726f93e8a97fe7e2f73358eed631e7e428 /dev-go
parentapp-admin/kpcli: stabilize 3.7 on ALLARCHES (diff)
downloadgentoo-9554c9575d4151f5b22a9c6803cd4acf65b2ca8e.tar.gz
gentoo-9554c9575d4151f5b22a9c6803cd4acf65b2ca8e.tar.bz2
gentoo-9554c9575d4151f5b22a9c6803cd4acf65b2ca8e.zip
dev-go/act: use go-module.eclass
Update to EAPI 8 Remove strip from RESTRICT, as this is set by the go-module.eclass already Closes: https://bugs.gentoo.org/844643 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/25586 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/act/act-1.6.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-go/act/act-1.6.0.ebuild b/dev-go/act/act-1.6.0.ebuild
index 0d9fa048573c..3a2dd997297d 100644
--- a/dev-go/act/act-1.6.0.ebuild
+++ b/dev-go/act/act-1.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit golang-base toolchain-funcs
+inherit go-module toolchain-funcs
DESCRIPTION="Automated Component Toolkit code generator"
HOMEPAGE="https://github.com/Autodesk/AutomaticComponentToolkit"
@@ -14,7 +14,7 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-RESTRICT="strip test"
+RESTRICT="test"
# Package does not follow the usual go directory structure
# Functions borrowed from dev-lang/go ebuild.