summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-23 13:02:42 +1000
committerSam James <sam@gentoo.org>2022-07-23 05:07:52 +0100
commitca76007e9ca8e3b23af55b769ed204f322acb99f (patch)
tree64a3cabc19fe4a8e7a2cbe67936ddc7509341fff /dev-haskell/aeson
parentdev-haskell/pandoc-types: drop 1.22 (diff)
downloadgentoo-ca76007e9ca8e3b23af55b769ed204f322acb99f.tar.gz
gentoo-ca76007e9ca8e3b23af55b769ed204f322acb99f.tar.bz2
gentoo-ca76007e9ca8e3b23af55b769ed204f322acb99f.zip
dev-haskell/aeson: add 2.0.3.0
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/aeson')
-rw-r--r--dev-haskell/aeson/Manifest2
-rw-r--r--dev-haskell/aeson/aeson-2.0.3.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-haskell/aeson/Manifest b/dev-haskell/aeson/Manifest
index 61768ab7b193..908e496ef813 100644
--- a/dev-haskell/aeson/Manifest
+++ b/dev-haskell/aeson/Manifest
@@ -1,3 +1,5 @@
DIST aeson-1.4.7.1.tar.gz 277911 BLAKE2B bffac6e82e7220f270fce44055859b27a97740b6f012f4e51d0970acd38a7bcd40d9bc3c4f1ba1df0df4d3d38dac0b8731dfdfe1f902b07a38efeaea842587d2 SHA512 236ed1b2cc4b39d49277cea5b787b6107c7efbe1c0d73de2005d400746bacf44c6b8ef5d26619395e24844f8948115685963ec7d03a998d0b728ab992e32e705
DIST aeson-1.5.6.0.cabal 6788 BLAKE2B b7ad53a5ef4c0a06ad39bcc6bb19c7f3635c629edafdd03acf8e45163170506d00b7843a17bc4bd062bcfb922da949e9ec562ca62f0929b74bc094ee213aadf9 SHA512 6da627332e2d7b4af33ff53718e84b4b9fa11bc8b8ba82dffc9c5ea9f290b7628aa8015e9b2c8798ad402e184ce70253b0fdf49b4f60e7e22e2346f2f319fcc0
DIST aeson-1.5.6.0.tar.gz 286364 BLAKE2B cc9524f025144b74dc70aca13576de935b24f1ae2befa027f6ae7d93b20bae8e5f399ed0147e351f1e46579d628923ef019be934572376cbe0a3b2ea497fcb01 SHA512 31e0339945aec6d84aec230c09001fe6e7926f008d3444d12264bb323d0a050515303fdc8eeb6563733594209d930cdd2f82eb4dfe4dd4d5c573748aaa71813d
+DIST aeson-2.0.3.0-rev1.cabal 5867 BLAKE2B c64638d037ee4599a15c2c2c051b569649f57663312aaebc10c2a47cf2dfd834d03e8e4c909d70874737fd407f46f75744052ebe9319cde8ef56e4676115dbe0 SHA512 54b3ed453d6ec93a73d4bb639132164e1ffa698e87076577da39137ec2bb62b0c1a2f66d9412e1adad97d7d6cc32a6738e0495b0c4d312c183d7a29d01a29784
+DIST aeson-2.0.3.0.tar.gz 297283 BLAKE2B e6784fd2081c56d6f2f2fb82b383478ab743fcce77568c430c2b62a79b4ee89901b7e278b1da948215215d50ef72bbdef128fb5dfb6679c92d30586d1406302e SHA512 546adaaf864ca40012a268d71f442479f0ad7c69e9f943391801570e227a2faa652494766f1f63b77c730e019e83ebdd7511426baa12792a28fbb470eca64552
diff --git a/dev-haskell/aeson/aeson-2.0.3.0.ebuild b/dev-haskell/aeson/aeson-2.0.3.0.ebuild
new file mode 100644
index 000000000000..ff87318ca821
--- /dev/null
+++ b/dev-haskell/aeson/aeson-2.0.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+#hackport: flags: -developer,-bytestring-builder,-fast
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast JSON parsing and encoding"
+HOMEPAGE="https://github.com/haskell/aeson"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cffi +ordered-keymap"
+
+RDEPEND=">=dev-haskell/attoparsec-0.14.2:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ >=dev-haskell/base-compat-batteries-0.10.0:=[profile?] <dev-haskell/base-compat-batteries-0.13:=[profile?]
+ >=dev-haskell/contravariant-1.4.1:=[profile?] <dev-haskell/contravariant-1.6:=[profile?]
+ >=dev-haskell/data-fix-0.3.2:=[profile?] <dev-haskell/data-fix-0.4:=[profile?]
+ >=dev-haskell/dlist-0.8.0.4:=[profile?] <dev-haskell/dlist-1.1:=[profile?]
+ >=dev-haskell/hashable-1.3.5.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/indexed-traversable-0.1.2:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?]
+ >=dev-haskell/onetuple-0.3.1:=[profile?] <dev-haskell/onetuple-0.4:=[profile?]
+ >=dev-haskell/primitive-0.7.3.0:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/quickcheck-2.14.2:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
+ >=dev-haskell/scientific-0.3.7.0:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semialign-1.2:=[profile?] <dev-haskell/semialign-1.3:=[profile?]
+ >=dev-haskell/strict-0.4:=[profile?] <dev-haskell/strict-0.5:=[profile?]
+ >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-short-0.1.5:=[profile?] <dev-haskell/text-short-0.2:=[profile?]
+ >=dev-haskell/th-abstraction-0.3.0.0:=[profile?] <dev-haskell/th-abstraction-0.5:=[profile?]
+ >=dev-haskell/these-1.1.1.1:=[profile?] <dev-haskell/these-1.2:=[profile?]
+ >=dev-haskell/time-compat-1.9.6:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.10.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.5:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-haskell/vector-0.12.0.1:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-haskell/witherable-0.4.2:=[profile?] <dev-haskell/witherable-0.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/base-compat
+ >=dev-haskell/base-orphans-0.5.3 <dev-haskell/base-orphans-0.9
+ dev-haskell/base16-bytestring
+ >=dev-haskell/diff-0.4 <dev-haskell/diff-0.5
+ >=dev-haskell/generic-deriving-1.10 <dev-haskell/generic-deriving-1.15
+ >=dev-haskell/integer-logarithms-1 <dev-haskell/integer-logarithms-1.1
+ >=dev-haskell/quickcheck-instances-0.3.26.1 <dev-haskell/quickcheck-instances-0.4
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ $(cabal_flag cffi cffi) \
+ --flag=-developer \
+ --flag=-fast \
+ $(cabal_flag ordered-keymap ordered-keymap)
+}