summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:41:26 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 08:59:59 +0100
commitebf9519c9be0c8f7fc945f7bd9a07760948d3b5f (patch)
tree257eff5a7d0690c51eabbb87e4ae3f2530358bd2 /dev-haskell/aeson
parentdev-haskell/quickcheck-instances: bump up to 0.3.22 (diff)
downloadgentoo-ebf9519c9be0c8f7fc945f7bd9a07760948d3b5f.tar.gz
gentoo-ebf9519c9be0c8f7fc945f7bd9a07760948d3b5f.tar.bz2
gentoo-ebf9519c9be0c8f7fc945f7bd9a07760948d3b5f.zip
dev-haskell/aeson: bump up to 1.4.7.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/aeson')
-rw-r--r--dev-haskell/aeson/Manifest1
-rw-r--r--dev-haskell/aeson/aeson-1.4.7.1.ebuild65
-rw-r--r--dev-haskell/aeson/metadata.xml59
3 files changed, 96 insertions, 29 deletions
diff --git a/dev-haskell/aeson/Manifest b/dev-haskell/aeson/Manifest
index 7973f44ecb60..a960cc0e8a7e 100644
--- a/dev-haskell/aeson/Manifest
+++ b/dev-haskell/aeson/Manifest
@@ -3,3 +3,4 @@ DIST aeson-0.7.0.6.tar.gz 141565 BLAKE2B cad9f7826ee36241414341a50ad3bc5f2540412
DIST aeson-0.8.0.2.tar.gz 143850 BLAKE2B 23c8167d29d9ce82b43ca07904ba21bb6e6c8fba8a0bd2cc4a94bdc6869b338f728238d5a824425b2438515b39f0aedcf3d105d0a37315bf955c0f1cd623ea0f SHA512 fb5a976302b1422c11b0d20848dfa6b9f596874e59dd325868269fd61f4b2ee2b4bf12683c3758d7f24566564cfddb6426e64fb1f159bb8feb2eb35fb223caf0
DIST aeson-0.9.0.1.tar.gz 154482 BLAKE2B 4ad5b665b1659279f5788c8a665916adc487bbd74138886b0dbf71eecfeba47d65734173e54062bcbee051f41bd7a536cd331c5f8b57c64a2b3aa4881f314df3 SHA512 04de524b10843fb12f8d51e72560d67a94e761edb515c472d891a61b56ab867c8fd8ed26d5fd7b2dc637a9b7ac1705e764a104e9253342984b755bb0f0e9128c
DIST aeson-1.0.2.1.tar.gz 241837 BLAKE2B a8a4e0c9315c0e3b1a35ea9f87945200a324383e0cdcaf941809fbfb55f4c5d9e94206059d1457a3e825c2a52fdad16544e0b3aba09c35957829a15b28972199 SHA512 2647cc22cec7bfbb9ac27e20a471333a7abd436bd338d8069093259fdf3829b04c16043ff669382461a4fdfa84dfd4f59837ece704f7a773ebf4aca21afa5e8e
+DIST aeson-1.4.7.1.tar.gz 277911 BLAKE2B bffac6e82e7220f270fce44055859b27a97740b6f012f4e51d0970acd38a7bcd40d9bc3c4f1ba1df0df4d3d38dac0b8731dfdfe1f902b07a38efeaea842587d2 SHA512 236ed1b2cc4b39d49277cea5b787b6107c7efbe1c0d73de2005d400746bacf44c6b8ef5d26619395e24844f8948115685963ec7d03a998d0b728ab992e32e705
diff --git a/dev-haskell/aeson/aeson-1.4.7.1.ebuild b/dev-haskell/aeson/aeson-1.4.7.1.ebuild
new file mode 100644
index 000000000000..cbb99b44a856
--- /dev/null
+++ b/dev-haskell/aeson/aeson-1.4.7.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -developer,-bytestring-builder
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast JSON parsing and encoding"
+HOMEPAGE="https://github.com/bos/aeson"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cffi fast"
+
+RDEPEND=">=dev-haskell/attoparsec-0.13.2.2:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/base-compat-batteries-0.10.0:=[profile?] <dev-haskell/base-compat-batteries-0.12:=[profile?]
+ >=dev-haskell/contravariant-1.4.1:=[profile?] <dev-haskell/contravariant-1.6:=[profile?]
+ >=dev-haskell/dlist-0.8.0.4:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/nats-1.1.1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/primitive-0.6.3.0:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/scientific-0.3.6.2:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.5:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/tagged-0.8.5:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/th-abstraction-0.2.8.0:=[profile?] <dev-haskell/th-abstraction-0.4:=[profile?]
+ >=dev-haskell/time-compat-1.9.2.2:=[profile?] <dev-haskell/time-compat-1.10:=[profile?]
+ >=dev-haskell/transformers-compat-0.6.2:=[profile?] <dev-haskell/transformers-compat-0.7:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.8.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.3:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-haskell/vector-0.12.0.1:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/void-0.7.2:=[profile?] <dev-haskell/void-0.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/base-compat
+ >=dev-haskell/base-orphans-0.5.3 <dev-haskell/base-orphans-0.9
+ dev-haskell/base16-bytestring
+ >=dev-haskell/diff-0.4 <dev-haskell/diff-0.5
+ >=dev-haskell/generic-deriving-1.10 <dev-haskell/generic-deriving-1.14
+ >=dev-haskell/hashable-time-0.2 <dev-haskell/hashable-time-0.3
+ >=dev-haskell/integer-logarithms-1 <dev-haskell/integer-logarithms-1.1
+ >=dev-haskell/quickcheck-2.10.0.1 <dev-haskell/quickcheck-2.14
+ >=dev-haskell/quickcheck-instances-0.3.21 <dev-haskell/quickcheck-instances-0.4
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ $(cabal_flag cffi cffi) \
+ --flag=-developer \
+ $(cabal_flag fast fast)
+}
diff --git a/dev-haskell/aeson/metadata.xml b/dev-haskell/aeson/metadata.xml
index 343bb16f130d..057fca61d1ca 100644
--- a/dev-haskell/aeson/metadata.xml
+++ b/dev-haskell/aeson/metadata.xml
@@ -8,66 +8,67 @@
<longdescription>
A JSON parsing and encoding library optimized for ease of use
and high performance.
-
+
/Note/: if you use GHCi or Template Haskell, please see the
@README@ file for important details about building this package,
and other packages that depend on it:
&lt;https://github.com/mailrank/aeson#readme&gt;
-
+
Parsing performance on a late 2010 MacBook Pro (2.66GHz Core i7),
for mostly-English tweets from Twitter's JSON search API:
-
+
* 0.8 KB, 32-bit GHC 6.12.3: 30538 msg\/sec (24.9 MB\/sec)
-
+
* 0.8 KB, 64-bit GHC 7.0.3: 31204 msg\/sec (25.4 MB\/sec)
-
+
* 6.4 KB, 32-bit GHC 6.12.3: 6731 msg\/sec (42.3 MB\/sec)
-
+
* 6.4 KB, 64-bit GHC 7.0.3: 6627 msg\/sec (41.7 MB\/sec)
-
+
* 11.8 KB, 32-bit GHC 6.12.3: 3751 msg\/sec (43.2 MB\/sec)
-
+
* 11.8 KB, 64-bit GHC 7.0.3: 3381 msg\/sec (38.9 MB\/sec)
-
+
* 31.2 KB, 32-bit GHC 6.12.3: 1306 msg\/sec (39.8 MB\/sec)
-
+
* 31.2 KB, 64-bit GHC 7.0.3: 1132 msg\/sec (34.5 MB\/sec)
-
+
* 61.5 KB, 32-bit GHC 6.12.3: 616 msg\/sec (37.0 MB\/sec)
-
+
* 61.5 KB, 64-bit GHC 7.0.3: 534 msg\/sec (32.1 MB\/sec)
-
+
Handling heavily-escaped text is a little more work. Here is
parsing performance with Japanese tweets, where much of the text
is entirely Unicode-escaped.
-
+
* 14.6 KB, 32-bit GHC 6.12.3: 2315 msg\/sec (33.1 MB\/sec)
-
+
* 14.6 KB, 64-bit GHC 7.0.3: 1986 msg\/sec (28.4 MB\/sec)
-
+
* 44.1 KB, 32-bit GHC 6.12.3: 712 msg\/sec (30.7 MB\/sec)
-
+
* 44.1 KB, 64-bit GHC 7.0.3: 634 msg\/sec (27.3 MB\/sec)
-
+
* 82.9 KB, 32-bit GHC 6.12.3: 377 msg\/sec (30.5 MB\/sec)
-
+
* 82.9 KB, 64-bit GHC 7.0.3: 332 msg\/sec (26.9 MB\/sec)
-
+
Encoding performance on the same machine and data:
-
+
* English, 854 bytes: 43439 msg\/sec (35.4 MB/sec)
-
+
* English, 6.4 KB: 7127 msg\/sec (44.8 MB/sec)
-
+
* Engish, 61.5 KB: 765 msg\/sec (46.0 MB/sec)
-
+
* Japanese, 14.6 KB: 4727 msg\/sec (67.5 MB/sec)
-
+
* Japanese, 44.1 KB: 1505 msg\/sec (64.8 MB/sec)
-
+
(A note on naming: in Greek mythology, Aeson was the father of Jason.)
</longdescription>
- <upstream>
- <remote-id type="github">bos/aeson</remote-id>
- </upstream>
+ <use>
+ <flag name="cffi">Controls whether to include c-ffi bits or pure haskell. Default to False for security.</flag>
+ <flag name="fast">compile without optimizations</flag>
+ </use>
</pkgmetadata>