summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 20:52:45 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:48 +0000
commit06a5d4fc9d56c34a8db800b0ac891a50bafdba6a (patch)
treea6cecee03e6dcefd2b54e0704778bcfe3bdcfdf0 /dev-haskell/ansi-wl-pprint
parentdev-haskell/ansi-terminal: keyword 0.10.3 for ~ppc64 (diff)
downloadgentoo-06a5d4fc9d56c34a8db800b0ac891a50bafdba6a.tar.gz
gentoo-06a5d4fc9d56c34a8db800b0ac891a50bafdba6a.tar.bz2
gentoo-06a5d4fc9d56c34a8db800b0ac891a50bafdba6a.zip
dev-haskell/ansi-wl-pprint: add 0.6.9
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/ansi-wl-pprint')
-rw-r--r--dev-haskell/ansi-wl-pprint/Manifest2
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/ansi-wl-pprint/Manifest b/dev-haskell/ansi-wl-pprint/Manifest
index 49f62e483b55..6bf81bced889 100644
--- a/dev-haskell/ansi-wl-pprint/Manifest
+++ b/dev-haskell/ansi-wl-pprint/Manifest
@@ -1 +1,3 @@
DIST ansi-wl-pprint-0.6.8.2.tar.gz 16491 BLAKE2B dd0619b5ee9f043b225dcafdc7dc4f8b095ccd24644f03cd46c3596765ecb3c2eba7955f5cf4032664b9da9473ee508c59c4b18e7b30725ab81c00fa96e5f2ad SHA512 00c39dcdd90071011d2db6e196c472fddc61bf3ee4baed0414de1a1ef1e13801fceb647a718018e1a644d2276845af7bc58d5bf72dcb35d193ef6391ba2f8ac3
+DIST ansi-wl-pprint-0.6.9-rev3.cabal 2425 BLAKE2B ea9e5f58811e8ffcda756b73c8ef5c7507fc25ce183b4a6fa3872d703752a74ad8de63376b900d6b61b077be0af9099b2b3da3240b7267ae2f72bcd50d412e22 SHA512 f7af7c4adcf43ffa199bb71828442e9b99eecb1450ff966771ee0f3b9b249cb20e7d2a70d1c54955b2f162a1acf0b6912f7cee09f00686da31b6522f501c05bf
+DIST ansi-wl-pprint-0.6.9.tar.gz 16723 BLAKE2B c0ddfa0651ab8bc008546d3c5520cb85c3e7d7c676c634e89978de0a4e3d2927e4bce6337306b0d0d5821af3d0202eafea48e203c298e707b6b82b8a5c6404e6 SHA512 2a66236f740f0b45b6133555e8b1315dc85ece1c16dd51e4aa7f31d2fee03d66869af5f81e6383aa840f503c2cad46f3655f53b784ebca7b3480efb53eea2a04
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild
new file mode 100644
index 000000000000..dcebf67d8c3d
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_HACKAGE_REVISION="3"
+inherit haskell-cabal
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.9.1:=[profile?] <dev-haskell/ansi-terminal-0.12:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}