summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:28:27 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:31:23 +0100
commitb03ef62a984da11457b2f416facb05f5c87057bf (patch)
tree7bfa61cefef113804a1d5da4bee1a0e8c13df126 /dev-haskell/arithmoi/arithmoi-0.11.0.1.ebuild
parentdev-haskell/smallcheck: bump up to 1.2.0 (diff)
downloadgentoo-b03ef62a984da11457b2f416facb05f5c87057bf.tar.gz
gentoo-b03ef62a984da11457b2f416facb05f5c87057bf.tar.bz2
gentoo-b03ef62a984da11457b2f416facb05f5c87057bf.zip
dev-haskell/arithmoi: bump up to 0.11.0.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/arithmoi/arithmoi-0.11.0.1.ebuild')
-rw-r--r--dev-haskell/arithmoi/arithmoi-0.11.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/arithmoi/arithmoi-0.11.0.1.ebuild b/dev-haskell/arithmoi/arithmoi-0.11.0.1.ebuild
new file mode 100644
index 000000000000..96a95a839f5e
--- /dev/null
+++ b/dev-haskell/arithmoi/arithmoi-0.11.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.5.9999
+#hackport: flags: -check-bounds
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
+HOMEPAGE="https://github.com/Bodigrim/arithmoi"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/chimera-0.3:=[profile?]
+ dev-haskell/constraints:=[profile?]
+ >=dev-haskell/exact-pi-0.5:=[profile?]
+ >=dev-haskell/integer-logarithms-1.0:=[profile?]
+ >=dev-haskell/integer-roots-1.0:=[profile?]
+ dev-haskell/mod:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/semirings-0.5.2:=[profile?]
+ >=dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-8.2.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( >=dev-haskell/quickcheck-2.10
+ >=dev-haskell/quickcheck-classes-0.6.3
+ >=dev-haskell/smallcheck-1.2 <dev-haskell/smallcheck-1.3
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.9 <dev-haskell/tasty-quickcheck-0.11
+ >=dev-haskell/tasty-rerun-1.1.17
+ >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds
+}