summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/atomic-primops
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/atomic-primops')
-rw-r--r--dev-haskell/atomic-primops/Manifest3
-rw-r--r--dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild32
-rw-r--r--dev-haskell/atomic-primops/atomic-primops-0.6.1.1.ebuild31
-rw-r--r--dev-haskell/atomic-primops/atomic-primops-0.7.ebuild31
-rw-r--r--dev-haskell/atomic-primops/metadata.xml18
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-haskell/atomic-primops/Manifest b/dev-haskell/atomic-primops/Manifest
new file mode 100644
index 000000000000..5294e087c5c6
--- /dev/null
+++ b/dev-haskell/atomic-primops/Manifest
@@ -0,0 +1,3 @@
+DIST atomic-primops-0.4.tar.gz 24982 SHA256 c0f51aa2ccf4ee6d3cece014dd9100347955d5b81eee5cdbf940bb22ac074f07 SHA512 981610ad2aa22a9e8a629f04bbf5d42f3a62dabde9787c2481597357a6f7bf9b894bc2c1bab8dfc92002789021704e2725abecac55a4fbd4c263821327cd8023 WHIRLPOOL e6d16167bdbdf32fe4db58e3f5c4f846a59763df24c40fbc437f6ade018a7d8fd968365a896311bf3f77e2b769cb88511902eeb44a3eab7f5f9279fd8d3a125e
+DIST atomic-primops-0.6.1.1.tar.gz 30423 SHA256 8c1c1962655c6af4a68657d0fa162188e6bb47b3dfe54806e2d0a402fa8196ba SHA512 02e1fd969320fb477b430b57333aba09fe4dabc04df9d03ea6996d6d11d6f2b442d28828d7cf77690fae35f3a90cc2222054466acdd214b5c5bde3cbdaf3b94e WHIRLPOOL 7cfef03eb1cc18e8153576c7bfa80dd59b4cff930e56836db311a861c9cdc108f645e3048f9faf611219e52858e0a9ab35e0ab4377fc058476effc62843d8320
+DIST atomic-primops-0.7.tar.gz 30560 SHA256 0f94066eeec9922e704a22de87b59b9433c88a4c502ab6cb6e83736ff1a9a2bd SHA512 5231515cb37e4f31b35232ff60ee8bd9c273ee8c9c1e08cb5c84b82d3381afb9301979a4774362145be22c08d5c4852afaaa3c7d67b8e1613abbb477c533b8a4 WHIRLPOOL 4596e3dc40157315b3564c38aedc5fa6bd49919cfdda674501a1e3406d843bbbd17dcb47e314effd31ca58ef1f123ee8727e8280f5c3f60352e646ccf2b7f725
diff --git a/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild b/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild
new file mode 100644
index 000000000000..b6aae0d751d2
--- /dev/null
+++ b/dev-haskell/atomic-primops/atomic-primops-0.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib haddock hoogle hscolour profile"
+inherit haskell-cabal
+
+DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree-queue/wiki"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-haskell/bits-atomic:=[profile?]
+ dev-haskell/cabal:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-lang/ghc-7.4.1:="
+DEPEND="${RDEPEND}
+ profile? ( !<dev-haskell/cabal-1.17 )
+ >=dev-haskell/cabal-1.8"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/atomic-primops/atomic-primops-0.6.1.1.ebuild b/dev-haskell/atomic-primops/atomic-primops-0.6.1.1.ebuild
new file mode 100644
index 000000000000..2e8ae83fa9f9
--- /dev/null
+++ b/dev-haskell/atomic-primops/atomic-primops-0.6.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree/wiki"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/atomic-primops/atomic-primops-0.7.ebuild b/dev-haskell/atomic-primops/atomic-primops-0.7.ebuild
new file mode 100644
index 000000000000..2e8ae83fa9f9
--- /dev/null
+++ b/dev-haskell/atomic-primops/atomic-primops-0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree/wiki"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/atomic-primops/metadata.xml b/dev-haskell/atomic-primops/metadata.xml
new file mode 100644
index 000000000000..2576b3c8008e
--- /dev/null
+++ b/dev-haskell/atomic-primops/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ After GHC 7.4 a new `casMutVar#` primop became available, but it's
+ difficult to use safely, because pointer equality is a highly
+ unstable property in Haskell. This library provides a safer method
+ based on the concept of "Tickets".
+
+ Also, this library uses the "foreign primop" capability of GHC to
+ add access to other variants that may be of
+ interest, specifically, compare and swap inside an array.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rrnewton/haskell-lockfree</remote-id>
+ </upstream>
+</pkgmetadata>