summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/basic-prelude
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/basic-prelude')
-rw-r--r--dev-haskell/basic-prelude/Manifest3
-rw-r--r--dev-haskell/basic-prelude/basic-prelude-0.3.10.ebuild34
-rw-r--r--dev-haskell/basic-prelude/basic-prelude-0.3.11.ebuild34
-rw-r--r--dev-haskell/basic-prelude/basic-prelude-0.4.1.ebuild33
-rw-r--r--dev-haskell/basic-prelude/metadata.xml23
5 files changed, 127 insertions, 0 deletions
diff --git a/dev-haskell/basic-prelude/Manifest b/dev-haskell/basic-prelude/Manifest
new file mode 100644
index 000000000000..7582751323e0
--- /dev/null
+++ b/dev-haskell/basic-prelude/Manifest
@@ -0,0 +1,3 @@
+DIST basic-prelude-0.3.10.tar.gz 4943 SHA256 a94c0c94ece5b21bc6ca9a939a118185c5c1e9acdbf93cb46114df79a21d0180 SHA512 c570be987680b5d1b298d096150423bf3c373cac2a17656a6f2a2c68740d0f51b1df24bf952b4bab22d750ed6e55e7d055f082ef65a06e067f706b8476490980 WHIRLPOOL db35f565cfdef951ec15008f54224a462207a8756db69907683f61640fadef5f7ee2447dd383392fce05c247bacb6031a200b8341fbcb57ed0b886678a4b97fc
+DIST basic-prelude-0.3.11.tar.gz 5234 SHA256 86368bff6df4fb89cbc3427b5872a2326d4f520e3db466c4e844704ed452cb16 SHA512 450fe8f2c628d93b4a092c29cf229e0722b31604204b3b82956ea19e682c0a3bf83665046425f422185c4b9ab22e65bd87788f814279cb6e4e4aa9057aac9445 WHIRLPOOL 4bf28c948e6b8742483aee3ea2a5b13bb62ba6a7ce16deff0334a3982cbd0b19a82c01e782f594826887866cd5e7b82d3999fc7e2f29ea7eec0d4a7c6571ded7
+DIST basic-prelude-0.4.1.tar.gz 5513 SHA256 4902038360cc6c60b33c65700e7447c88b58bf7eabf7b9d804e7a275aab73c10 SHA512 5a7d692cccc6e2a9dbc7a947611334583f8f99a455c302f4904b4c5461436cebc5e1a90d450990fa11927fe7f3dd41f10aca8720d538fb926ece11cdcd4a0a10 WHIRLPOOL a9f845bb49273041f30d01715ea0b1fed1870880eae0715d06a26c8e47cff12c2ab1e27379df28f79978cf96b586432fb83d5a40deff30263aeeb6a4932a95b2
diff --git a/dev-haskell/basic-prelude/basic-prelude-0.3.10.ebuild b/dev-haskell/basic-prelude/basic-prelude-0.3.10.ebuild
new file mode 100644
index 000000000000..488f53483e59
--- /dev/null
+++ b/dev-haskell/basic-prelude/basic-prelude-0.3.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An enhanced core prelude; a common foundation for alternate preludes"
+HOMEPAGE="https://github.com/snoyberg/basic-prelude"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hashable:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/readargs-1.2:=[profile?] <dev-haskell/readargs-1.3:=[profile?]
+ dev-haskell/safe:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/basic-prelude/basic-prelude-0.3.11.ebuild b/dev-haskell/basic-prelude/basic-prelude-0.3.11.ebuild
new file mode 100644
index 000000000000..6c271699aa56
--- /dev/null
+++ b/dev-haskell/basic-prelude/basic-prelude-0.3.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An enhanced core prelude; a common foundation for alternate preludes"
+HOMEPAGE="https://github.com/snoyberg/basic-prelude"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hashable:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/readargs-1.2:=[profile?] <dev-haskell/readargs-1.3:=[profile?]
+ dev-haskell/safe:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/basic-prelude/basic-prelude-0.4.1.ebuild b/dev-haskell/basic-prelude/basic-prelude-0.4.1.ebuild
new file mode 100644
index 000000000000..cd43685c3d10
--- /dev/null
+++ b/dev-haskell/basic-prelude/basic-prelude-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An enhanced core prelude; a common foundation for alternate preludes"
+HOMEPAGE="https://github.com/snoyberg/basic-prelude"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hashable:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/readargs-1.2:=[profile?] <dev-haskell/readargs-1.3:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/basic-prelude/metadata.xml b/dev-haskell/basic-prelude/metadata.xml
new file mode 100644
index 000000000000..7528b64335ca
--- /dev/null
+++ b/dev-haskell/basic-prelude/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The premise of @basic-prelude@ is that there are a lot of very commonly desired features missing from the standard @Prelude@, such as commonly used operators (@\&lt;$\&gt;@ and @&gt;=&gt;@, for instance) and imports for common datatypes (e.g., @ByteString@ and @Vector@). At the same time, there are lots of other components which are more debatable, such as providing polymorphic versions of common functions.
+
+ So @basic-prelude@ is intended to give a common foundation for a number of alternate preludes. The package provides two modules: @CorePrelude@ provides the common ground for other preludes to build on top of, while @BasicPrelude@ exports @CorePrelude@ together with commonly used list functions to provide a drop-in replacement for the standard @Prelude@.
+
+ Users wishing to have an improved @Prelude@ can use @BasicPrelude@. Developers wishing to create a new prelude should use @CorePrelude@.
+
+ Release history:
+
+ [0.3] Moved a number of exports from @BasicPrelude@ to @CorePrelude@ and vice-versa.
+
+ [0.2] Renamed @BasicPrelude@ to @CorePrelude@ and added a new @BasicPrelude@ module provided a full-featured @Prelude@ alternative. Also added a number of new exports.
+
+ [0.1] Initial version, code taken from @classy-prelude@ with a few minor tweaks.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/basic-prelude</remote-id>
+ </upstream>
+</pkgmetadata>