summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 17:34:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commitfe9bdcce74bdd3bdac5a7e49c0d20e97da64f7e2 (patch)
tree45a2795024b4c58c2790a0b5b58e68f3db3b0ba4 /dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
parentdev-haskell/auto-update: bump up to 0.1.3 (diff)
downloadgentoo-fe9bdcce74bdd3bdac5a7e49c0d20e97da64f7e2.tar.gz
gentoo-fe9bdcce74bdd3bdac5a7e49c0d20e97da64f7e2.tar.bz2
gentoo-fe9bdcce74bdd3bdac5a7e49c0d20e97da64f7e2.zip
dev-haskell/bits-atomic: tweak for gcc-5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild')
-rw-r--r--dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..ccf731538e55
--- /dev/null
+++ b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Atomic bit operations on memory locations for low-level synchronization"
+HOMEPAGE="http://hackage.haskell.org/package/bits-atomic"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-5.patch
+}