summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-27 07:52:09 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-27 07:52:09 +0100
commit30191f673e57b9ceebf65fb1c345b9174eb2f07f (patch)
tree2b3fd6035ce6e6721641d295698f2c75238b8d17 /dev-haskell/cabal/cabal-2.4.0.1.ebuild
parentdev-haskell/parsec: bump up to 3.1.13.0 (ghc-8.6 core lib) (diff)
downloadgentoo-30191f673e57b9ceebf65fb1c345b9174eb2f07f.tar.gz
gentoo-30191f673e57b9ceebf65fb1c345b9174eb2f07f.tar.bz2
gentoo-30191f673e57b9ceebf65fb1c345b9174eb2f07f.zip
dev-haskell/cabal: bump up to 2.4.0.1 (ghc-8.6 core lib)
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/cabal/cabal-2.4.0.1.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-2.4.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-2.4.0.1.ebuild b/dev-haskell/cabal/cabal-2.4.0.1.ebuild
new file mode 100644
index 000000000000..0b868d122cef
--- /dev/null
+++ b/dev-haskell/cabal/cabal-2.4.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: -bundled-binary-generic
+
+CABAL_FEATURES="lib profile" # Drop test-suite: circular depend
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.6
+#KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.0.0.2-no-bootstrap.patch)
+
+CABAL_CORE_LIB_GHC_PV="PM:8.6.1 PM:8.6.2 PM:8.6.3 PM:8.6.4 PM:8.6.5"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bundled-binary-generic
+}