summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:53:08 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:57:15 +0000
commita92a59a3db7f3378690b0c86fa037b8b7907c790 (patch)
treeadbbc15c005a38814f6deaa7eb3e75fc1d34888c /dev-haskell/cairo/cairo-0.13.3.1.ebuild
parentdev-vcs/git-annex: add missing patches (diff)
downloadgentoo-a92a59a3db7f3378690b0c86fa037b8b7907c790.tar.gz
gentoo-a92a59a3db7f3378690b0c86fa037b8b7907c790.tar.bz2
gentoo-a92a59a3db7f3378690b0c86fa037b8b7907c790.zip
dev-haskell/cairo: bump up to 0.13.3.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/cairo/cairo-0.13.3.1.ebuild')
-rw-r--r--dev-haskell/cairo/cairo-0.13.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/cairo/cairo-0.13.3.1.ebuild b/dev-haskell/cairo/cairo-0.13.3.1.ebuild
new file mode 100644
index 000000000000..4095861abf4a
--- /dev/null
+++ b/dev-haskell/cairo/cairo-0.13.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: cairo_ps:postscript,cairo_pdf:pdf,cairo_svg:svg
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Cairo library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+pdf +postscript +svg"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ x11-libs/cairo
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24
+ dev-haskell/gtk2hs-buildtools
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag pdf cairo_pdf) \
+ $(cabal_flag postscript cairo_ps) \
+ $(cabal_flag svg cairo_svg)
+}