summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/certificate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/certificate')
-rw-r--r--dev-haskell/certificate/Manifest3
-rw-r--r--dev-haskell/certificate/certificate-1.3.7.ebuild37
-rw-r--r--dev-haskell/certificate/certificate-1.3.8-r1.ebuild49
-rw-r--r--dev-haskell/certificate/certificate-1.3.8.ebuild32
-rw-r--r--dev-haskell/certificate/certificate-1.3.9.ebuild44
-rw-r--r--dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs46
-rw-r--r--dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch16
-rw-r--r--dev-haskell/certificate/metadata.xml17
8 files changed, 244 insertions, 0 deletions
diff --git a/dev-haskell/certificate/Manifest b/dev-haskell/certificate/Manifest
new file mode 100644
index 000000000000..ed6e6baa9dfe
--- /dev/null
+++ b/dev-haskell/certificate/Manifest
@@ -0,0 +1,3 @@
+DIST certificate-1.3.7.tar.gz 15009 SHA256 cae38c57ebd2a10fe6d03e37ec24690823da4ef67b1f2cba572fa0718b9a4e1b SHA512 e3238e5b76f0aeb908618eb2067b8d42b0a4c29797431082a4516c41de6a79ec5c87fc6d7b5b03c7388c853663d6a2d2a4c316d254e9198e3e406e538ca3df39 WHIRLPOOL 07bf063073e2da09b1222949dd23e0ed86543f5a948f6770945e57cc2cff1955618699af6dde1ea807d1f02a0182f2182f7ae8bd645ad243a6d22ab3382de29a
+DIST certificate-1.3.8.tar.gz 15025 SHA256 a006b7876417a8bc5cfd90a59bf2b01ea2efdfc08b26296bb004501d9593a3c5 SHA512 8e3764ca1d8a051e996e816bdaaa3311318ab1b2ff92f02872b6966f63888b803f87223890c093d3f4c03a5381f826f3107fb552032caa5409a17fcab98e0244 WHIRLPOOL a2853fe36a2f22007d3a456c132faedc021d623d2d6294c024929671ae920070141cc50a2aa1dd06ff6c31670ff18e368733fa2cd714df9e6bfe1b4f099f0b22
+DIST certificate-1.3.9.tar.gz 15018 SHA256 e6257b4b0e884db8a817d265d9a7f9a6c76af8190504f32dadbbf64b0fcee5a1 SHA512 85ad7d1f3def68152824d0be4ccc3fb991903867fac68927eac34db366ce6f8201468a3e73c336fef6feae1ce550f614fc3ab89447b4ec7a67ac279902a815f9 WHIRLPOOL 3094c5fa08e397f3981128c52742f4e0ff90b4169227a5e897cef9b9afc3d4bfd1bb4a26c6b5e1ad3da7e52565ca331b69c048a5fd3c8cf87b45063eb5ac5b8a
diff --git a/dev-haskell/certificate/certificate-1.3.7.ebuild b/dev-haskell/certificate/certificate-1.3.7.ebuild
new file mode 100644
index 000000000000..aeabe1beee78
--- /dev/null
+++ b/dev-haskell/certificate/certificate-1.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Certificates and Key Reader/Writer"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # due missing tests
+
+RDEPEND=">=dev-haskell/asn1-data-0.7.1:=[profile?]
+ <dev-haskell/asn1-data-0.8.0:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.3:=[profile?]
+ <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ =dev-haskell/pem-0.1*:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'crypto-pubkey-types >= 0.3 && < 0.4' 'crypto-pubkey-types >= 0.3 && < 0.5'
+}
diff --git a/dev-haskell/certificate/certificate-1.3.8-r1.ebuild b/dev-haskell/certificate/certificate-1.3.8-r1.ebuild
new file mode 100644
index 000000000000..3c7ee29a99bd
--- /dev/null
+++ b/dev-haskell/certificate/certificate-1.3.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Certificates and Key Reader/Writer"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="executable test"
+RESTRICT="test" # due missing tests
+
+RDEPEND=">=dev-haskell/asn1-data-0.7.1:=[profile?]
+ <dev-haskell/asn1-data-0.8.0:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.3:=[profile?]
+ <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ executable? ( dev-haskell/cmdargs:=[profile?]
+ dev-haskell/crypto-pubkey:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ )
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2:=[profile?]
+ )"
+
+src_prepare() {
+ cabal_chdeps \
+ 'pem >= 0.1 && < 0.2' 'pem >= 0.1 && < 0.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/certificate/certificate-1.3.8.ebuild b/dev-haskell/certificate/certificate-1.3.8.ebuild
new file mode 100644
index 000000000000..566f27289650
--- /dev/null
+++ b/dev-haskell/certificate/certificate-1.3.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Certificates and Key Reader/Writer"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # due missing tests
+
+RDEPEND=">=dev-haskell/asn1-data-0.7.1:=[profile?]
+ <dev-haskell/asn1-data-0.8.0:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.3:=[profile?]
+ <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ =dev-haskell/pem-0.1*:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/certificate/certificate-1.3.9.ebuild b/dev-haskell/certificate/certificate-1.3.9.ebuild
new file mode 100644
index 000000000000..fef4e831bf9e
--- /dev/null
+++ b/dev-haskell/certificate/certificate-1.3.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Certificates and Key Reader/Writer"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="executable test"
+RESTRICT="test" # due missing tests
+
+RDEPEND=">=dev-haskell/asn1-data-0.7.1:=[profile?] <dev-haskell/asn1-data-0.8.0:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ executable? ( dev-haskell/cmdargs:=[profile?]
+ dev-haskell/crypto-pubkey:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.9-ghc-7.10.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs b/dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs
new file mode 100644
index 000000000000..d97947f2b233
--- /dev/null
+++ b/dev-haskell/certificate/files/certificate-1.3.6/Tests/Unit.hs
@@ -0,0 +1,46 @@
+module Tests.Unit
+ ( runTests
+ ) where
+
+import System.Directory
+import Test.HUnit
+import Control.Monad
+import Control.Applicative ((<$>))
+import Control.Exception
+import qualified Data.ByteString as B
+import qualified Data.ByteString.Lazy as L
+import Data.Certificate.X509
+import Data.List (isPrefixOf)
+
+-- FIXME : make unit tests portable to run on osX and windows
+import System.Certificate.X509
+import Data.CertificateStore
+
+checkCert (X509 c mraw rawCert sigalg sigbits) = do
+ let errs =
+ (checkSigAlg $ certSignatureAlg c) ++
+ (checkPubKey $ certPubKey c) ++
+ (checkExtensions $ certExtensions c) ++
+ (checkBodyRaw rawCert mraw)
+ when (errs /= []) $ do
+ putStrLn ("error decoding")
+ mapM_ (putStrLn . (" " ++)) errs
+ where
+ checkExtensions ext = []
+
+ checkSigAlg (SignatureALG_Unknown oid) = ["unknown signature algorithm " ++ show oid]
+ checkSigAlg _ = []
+
+ checkPubKey (PubKeyUnknown oid _) = ["unknown public key alg " ++ show (certPubKey c)]
+ checkPubKey _ = []
+
+ checkBodyRaw (Just x) (Just y) = if findsubstring y x then [] else ["cannot find body cert in original raw file"]
+ checkBodyRaw _ _ = []
+
+ findsubstring a b
+ | L.null b = False
+ | a `L.isPrefixOf` b = True
+ | otherwise = findsubstring a (L.drop 1 b)
+
+runTests :: IO ()
+runTests = getSystemCertificateStore >>= mapM_ checkCert . listCertificates
diff --git a/dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch b/dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch
new file mode 100644
index 000000000000..07a53256ded8
--- /dev/null
+++ b/dev-haskell/certificate/files/certificate-1.3.9-ghc-7.10.patch
@@ -0,0 +1,16 @@
+diff --git a/Data/Certificate/X509/Cert.hs b/Data/Certificate/X509/Cert.hs
+index 4abfadf..15e7bf8 100644
+--- a/Data/Certificate/X509/Cert.hs
++++ b/Data/Certificate/X509/Cert.hs
+@@ -1,2 +1,3 @@
++{-# LANGUAGE FlexibleContexts #-}
+ module Data.Certificate.X509.Cert
+ (
+diff --git a/Data/Certificate/X509/Ext.hs b/Data/Certificate/X509/Ext.hs
+index 7595f14..8963a55 100644
+--- a/Data/Certificate/X509/Ext.hs
++++ b/Data/Certificate/X509/Ext.hs
+@@ -1,2 +1,3 @@
++{-# LANGUAGE FlexibleContexts #-}
+ -- |
+ -- Module : Data.Certificate.X509.Ext
diff --git a/dev-haskell/certificate/metadata.xml b/dev-haskell/certificate/metadata.xml
new file mode 100644
index 000000000000..50833e1be936
--- /dev/null
+++ b/dev-haskell/certificate/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Certificates and Key reader/writer
+
+ At the moment only X509 certificate and unencrypted private key are supported,
+ but will include PGP certificate and pkcs8 private keys
+ </longdescription>
+ <use>
+ <flag name="executable">Build the executable</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-certificate</remote-id>
+ </upstream>
+</pkgmetadata>