summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cipher-des
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cipher-des')
-rw-r--r--dev-haskell/cipher-des/Manifest2
-rw-r--r--dev-haskell/cipher-des/cipher-des-0.0.4.ebuild32
-rw-r--r--dev-haskell/cipher-des/cipher-des-0.0.6.ebuild32
-rw-r--r--dev-haskell/cipher-des/metadata.xml11
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-haskell/cipher-des/Manifest b/dev-haskell/cipher-des/Manifest
new file mode 100644
index 000000000000..982e284f3ef1
--- /dev/null
+++ b/dev-haskell/cipher-des/Manifest
@@ -0,0 +1,2 @@
+DIST cipher-des-0.0.4.tar.gz 7806 SHA256 18c73ecb7d17eab284b01d00f07680e60ce869a0510d70cfc200fa0ef661b7a3 SHA512 7eb3e9d270b8583f01a70b4398a24e15f3efdad6477fca590ad7cd18fdefc1e7438b0c500cd11f6c50f4bce034c9d97540e2e994940e3b17e30a27dc261c1360 WHIRLPOOL e1820d04096123a1b077c485640224b97da6cf24d4c5ef5309d788ac12e5a15ea82f6445d96648f0f2170f8c0b9e24a50101a676eb4ba6f933308c440ca3dd8d
+DIST cipher-des-0.0.6.tar.gz 7857 SHA256 85f1bccdec625a120ecf83b861afcb6478f8f899ceaa06fc083e642b54ff4ac7 SHA512 290b72fb9d6da58450e43742b313ff295cf3bf88242de33069e3183df7f726b69174dae35572a3d7d3a356aef4d4067104c41c1bd06fead8fec227ff92ba10c9 WHIRLPOOL 1950c7569333f379af9b7024f3c07d77805a60c1072eccb14ba471ceb57958361dbb789546e8a0962b2c36fa60980bb4f67443b358df6eba963804cb40741ab0
diff --git a/dev-haskell/cipher-des/cipher-des-0.0.4.ebuild b/dev-haskell/cipher-des/cipher-des-0.0.4.ebuild
new file mode 100644
index 000000000000..dc8235d3f031
--- /dev/null
+++ b/dev-haskell/cipher-des/cipher-des-0.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="DES and 3DES primitives"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-des/cipher-des-0.0.6.ebuild b/dev-haskell/cipher-des/cipher-des-0.0.6.ebuild
new file mode 100644
index 000000000000..f6d4d1b033fe
--- /dev/null
+++ b/dev-haskell/cipher-des/cipher-des-0.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="DES and 3DES primitives"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-des/metadata.xml b/dev-haskell/cipher-des/metadata.xml
new file mode 100644
index 000000000000..19680bfaeaad
--- /dev/null
+++ b/dev-haskell/cipher-des/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ DES and 3DES primitives
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>