summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/configfile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/configfile')
-rw-r--r--dev-haskell/configfile/Manifest3
-rw-r--r--dev-haskell/configfile/configfile-1.1.1.ebuild31
-rw-r--r--dev-haskell/configfile/configfile-1.1.2.ebuild40
-rw-r--r--dev-haskell/configfile/configfile-1.1.4.ebuild40
-rw-r--r--dev-haskell/configfile/metadata.xml23
5 files changed, 137 insertions, 0 deletions
diff --git a/dev-haskell/configfile/Manifest b/dev-haskell/configfile/Manifest
new file mode 100644
index 000000000000..eb74d787d68e
--- /dev/null
+++ b/dev-haskell/configfile/Manifest
@@ -0,0 +1,3 @@
+DIST ConfigFile-1.1.1.tar.gz 28269 SHA256 55067e4b6d5f532d6e28c739869742a011490905e24894da9015368aed825e70 SHA512 2c8cb8fe633521999416946379c03b8e169d46cfe430701d5c723faa65917df47fd9753098e575157b036d208ca91b3eec8f4eeaeaaf4152dbebb9356ba8eb95 WHIRLPOOL 571a395902536064ed604da3cabf9d3d4d9e2aeb1cc3b5b25e2cc67170e9eb94c4efe6715ca527ea3f5f97cd108415a6d24e8dbffbc0bc89ce31abfead148069
+DIST ConfigFile-1.1.2.tar.gz 28947 SHA256 38f6df24926c4952af198cbc9e45e72a62af73adeef097767889e9321bca2d76 SHA512 4bfc196d1cf2083bcd6313828efee53a971b0a08e25f44efa1427a27890358916daa42ae2db9996e65c802119c99e60eafdc1ca0ebcf9fcfafd72d9aee065c55 WHIRLPOOL 1ff963f9139665a13d581824b274c6d329daddbdb3c39876a7aef26eefd99c27d80d204571eb00a4107faa2adcb81a785e7f649d21ac570643fbafbbbc000ec7
+DIST ConfigFile-1.1.4.tar.gz 28969 SHA256 ae087b359ff2945a62b671449227e0a811d143ee651179f4e7e9c66548e0f514 SHA512 4455110c95172461b2d82ae88ba4f386d5e49ddd7f7def83714d2f6198090f0d121166eece3efa735341da9bbc0029e704be00d3e671d24ad27e838dfe913776 WHIRLPOOL 85c80d4dead287db46ca251cd4f49ad5bb3fa0df08d0ebee5f113aa8fa0f9a09f395a3b2c3a43a97517a3201df9c443f1f4cabf45f7e71b8c9f92db7fbbf3214
diff --git a/dev-haskell/configfile/configfile-1.1.1.ebuild b/dev-haskell/configfile/configfile-1.1.1.ebuild
new file mode 100644
index 000000000000..1f7e1be66228
--- /dev/null
+++ b/dev-haskell/configfile/configfile-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ConfigFile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Configuration file reading & writing"
+HOMEPAGE="http://software.complete.org/configfile"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/missingh-1.0.0[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/parsec[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/configfile/configfile-1.1.2.ebuild b/dev-haskell/configfile/configfile-1.1.2.ebuild
new file mode 100644
index 000000000000..12482c443da4
--- /dev/null
+++ b/dev-haskell/configfile/configfile-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ConfigFile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Configuration file reading & writing"
+HOMEPAGE="http://software.complete.org/configfile"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="buildtests"
+
+RDEPEND=">=dev-haskell/missingh-1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ buildtests? ( dev-haskell/hunit:=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildtests buildtests)
+}
diff --git a/dev-haskell/configfile/configfile-1.1.4.ebuild b/dev-haskell/configfile/configfile-1.1.4.ebuild
new file mode 100644
index 000000000000..fd7ffc8721ae
--- /dev/null
+++ b/dev-haskell/configfile/configfile-1.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="ConfigFile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Configuration file reading & writing"
+HOMEPAGE="http://software.complete.org/configfile"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="buildtests"
+
+RDEPEND=">=dev-haskell/missingh-1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ buildtests? ( dev-haskell/hunit:=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildtests buildtests)
+}
diff --git a/dev-haskell/configfile/metadata.xml b/dev-haskell/configfile/metadata.xml
new file mode 100644
index 000000000000..920e54837931
--- /dev/null
+++ b/dev-haskell/configfile/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Parser and writer for handling sectioned config files in
+ Haskell.
+
+ The ConfigFile module works with configuration files in a standard
+ format that is easy for the user to edit, easy for the programmer
+ to work with, yet remains powerful and flexible. It is inspired by,
+ and compatible with, Python&#39;s ConfigParser module. It uses files
+ that resemble Windows .INI-style files, but with numerous
+ improvements.
+
+ ConfigFile provides simple calls to both read and write config files.
+ It&#39;s possible to make a config file parsable by this module,
+ the Unix shell, and make.
+ </longdescription>
+<use>
+ <flag name='buildtests'>Build the executable to run unit tests.</flag>
+</use>
+</pkgmetadata>