summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/convertible
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/convertible')
-rw-r--r--dev-haskell/convertible/Manifest3
-rw-r--r--dev-haskell/convertible/convertible-1.0.10.0.ebuild52
-rw-r--r--dev-haskell/convertible/convertible-1.0.11.1.ebuild49
-rw-r--r--dev-haskell/convertible/convertible-1.1.0.0-r1.ebuild50
-rw-r--r--dev-haskell/convertible/files/convertible-1.0.10.0-time-1.2.patch13
-rw-r--r--dev-haskell/convertible/metadata.xml13
6 files changed, 180 insertions, 0 deletions
diff --git a/dev-haskell/convertible/Manifest b/dev-haskell/convertible/Manifest
new file mode 100644
index 000000000000..05b5e4a8ba54
--- /dev/null
+++ b/dev-haskell/convertible/Manifest
@@ -0,0 +1,3 @@
+DIST convertible-1.0.10.0.tar.gz 23231 SHA256 219cba91e1b95334602de0f35554100fcbcc852b2efaa0aab8bfbb0a48eb12de SHA512 727f743420e8597e626a57b77426d37d1f0f0de47b06c2600cc05a4792861909c9aa622970d65e72f28eef2334805f659309861c9e58c2c543fcfd187e6fa2f4 WHIRLPOOL 72e2c29bb4a5cd9777834db3e374d7fb905fa8424a572edcbc0dc5c615291ee9526885b3d43144d74b892d1ed2090f90c0b45a38fd7d1366fda762208c4a25a9
+DIST convertible-1.0.11.1.tar.gz 14478 SHA256 46d26e9fec9034bcb27334ba378e8735ac3126eb8573b4dbd1a06b77b350a0e4 SHA512 50082727409c450657bef534af94e8a58e8a3f97fa59d8f24f34d5b72e8335a41c3678036eafd8831f4748c6f1158cef96950d24c53e8402a4b9a7778640a9b1 WHIRLPOOL ae154ebf1df64b80ac2c603d157beae2c4edce9f1da5760ea8171094d778002123e2b8de2a9f5e28a3bdc0db90b70266d67693b16a3abe4c66929aacecf93d34
+DIST convertible-1.1.0.0.tar.gz 14087 SHA256 13c4943c302700a207426aabcd6dab5a5de85de2353acacbcf4159e924f9835d SHA512 33b797643f493c3c7b36b290a89b53010740407ec1f41b9727b04df72cf1807b8d3d234a4758cd14de5e3fd89138ae5182a9672c015f5d581f14132cf5d1217f WHIRLPOOL 025ca3c8eadb5d65a734adb419f1a22b1b2852414de57bffda3e6c991fb9e3b126bf41fcde64689d270ad6206bdc65b3357c32f80560f976e156d97898789066
diff --git a/dev-haskell/convertible/convertible-1.0.10.0.ebuild b/dev-haskell/convertible/convertible-1.0.10.0.ebuild
new file mode 100644
index 000000000000..e5f9ffbb4838
--- /dev/null
+++ b/dev-haskell/convertible/convertible-1.0.10.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Typeclasses and instances for converting between types"
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/convertible"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-haskell/mtl
+ >=dev-haskell/text-0.7
+ >=dev-lang/ghc-6.8.2
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck:2
+ dev-haskell/testpack
+ )
+ "
+
+PATCHES=("${FILESDIR}/${PN}-1.0.10.0-time-1.2.patch")
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/convertible/convertible-1.0.11.1.ebuild b/dev-haskell/convertible/convertible-1.0.11.1.ebuild
new file mode 100644
index 000000000000..6927d2e44f3c
--- /dev/null
+++ b/dev-haskell/convertible/convertible-1.0.11.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Typeclasses and instances for converting between types"
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/convertible"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-haskell/mtl[profile?]
+ >=dev-haskell/text-0.7[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck:2
+ dev-haskell/testpack
+ )
+ "
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/convertible/convertible-1.1.0.0-r1.ebuild b/dev-haskell/convertible/convertible-1.1.0.0-r1.ebuild
new file mode 100644
index 000000000000..38962da4dc4e
--- /dev/null
+++ b/dev-haskell/convertible/convertible-1.1.0.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Typeclasses and instances for converting between types"
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/convertible"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.0:2=[profile?]
+ >=dev-haskell/testpack-2.0:=[profile?] )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/convertible/files/convertible-1.0.10.0-time-1.2.patch b/dev-haskell/convertible/files/convertible-1.0.10.0-time-1.2.patch
new file mode 100644
index 000000000000..e5a60351b1c3
--- /dev/null
+++ b/dev-haskell/convertible/files/convertible-1.0.10.0-time-1.2.patch
@@ -0,0 +1,13 @@
+diff --git a/convertible.cabal b/convertible.cabal
+index 377562d..98b7cc7 100644
+--- a/convertible.cabal
++++ b/convertible.cabal
+@@ -50,7 +50,7 @@ flag time_gte_113
+
+ library
+ if flag(splitBase)
+- Build-Depends: base>=3 && <5, old-time, time>=1.1.2.4 && <=1.2.0.3,
++ Build-Depends: base>=3 && <5, old-time, time>=1.1.2.4 && < 1.3,
+ bytestring, containers, old-locale
+ if flag(time_gte_113)
+ Build-Depends: time>=1.1.3
diff --git a/dev-haskell/convertible/metadata.xml b/dev-haskell/convertible/metadata.xml
new file mode 100644
index 000000000000..88ecc722c6e3
--- /dev/null
+++ b/dev-haskell/convertible/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Convertible provides a typeclass with a single function
+ that is designed to help convert between different types: numeric
+ values, dates and times, and the like. The conversions perform bounds
+ checking and return a pure 'Either' value. This means that you need
+ not remember which specific function performs the conversion you
+ desire.
+ </longdescription>
+</pkgmetadata>