summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cprng-aes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cprng-aes')
-rw-r--r--dev-haskell/cprng-aes/Manifest2
-rw-r--r--dev-haskell/cprng-aes/cprng-aes-0.5.2.ebuild29
-rw-r--r--dev-haskell/cprng-aes/cprng-aes-0.6.1.ebuild28
-rw-r--r--dev-haskell/cprng-aes/metadata.xml25
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/cprng-aes/Manifest b/dev-haskell/cprng-aes/Manifest
new file mode 100644
index 000000000000..a7c746726c66
--- /dev/null
+++ b/dev-haskell/cprng-aes/Manifest
@@ -0,0 +1,2 @@
+DIST cprng-aes-0.5.2.tar.gz 4903 SHA256 ee0a5c27396c0257af5ebb4882b31e3ab14d8b160e916dbdc031733f506bc8d9 SHA512 bcc658c5ecac7b856ae128938c467cc4762089128a49716d8b16de1649a15206a12d6b624e82ec1564fca46df9b03ee4d277a2c641af787a1f758a11262bbcca WHIRLPOOL 20ebc57c54eeca6144730f4b0d726750959810c52a9cfd32f55c69d50ea26a81a0058e9e102915af31ef22aba807f7104cc88d80e292f147b499ce3c3a8efb60
+DIST cprng-aes-0.6.1.tar.gz 4396 SHA256 64592a01de8c6683c5e29f538dceee918887ffe211d87214a2e38559d72c21f3 SHA512 839a3a449edf996b0061a989058ed59625d8a849e852217c047b9d9b59b58504c0efaca699f75beea3ebcad8284f55c1f53b523dbebb10f56e705506bfccb5f5 WHIRLPOOL ba141a933e1345ee2db2d87d1a422711488993f116407949b37223e8e1fbe10f78886764fc55eb6da42574f130ff34cc6da82a6a122b5db480527426dc433cf5
diff --git a/dev-haskell/cprng-aes/cprng-aes-0.5.2.ebuild b/dev-haskell/cprng-aes/cprng-aes-0.5.2.ebuild
new file mode 100644
index 000000000000..d1f111edf94e
--- /dev/null
+++ b/dev-haskell/cprng-aes/cprng-aes-0.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Crypto Pseudo Random Number Generator using AES in counter mode"
+HOMEPAGE="http://github.com/vincenthz/hs-cprng-aes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cipher-aes-0.2:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ >=dev-haskell/crypto-random-0.0.7:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/cprng-aes/cprng-aes-0.6.1.ebuild b/dev-haskell/cprng-aes/cprng-aes-0.6.1.ebuild
new file mode 100644
index 000000000000..6cd688e12222
--- /dev/null
+++ b/dev-haskell/cprng-aes/cprng-aes-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Crypto Pseudo Random Number Generator using AES in counter mode"
+HOMEPAGE="http://github.com/vincenthz/hs-cprng-aes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cipher-aes-0.2.9:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ >=dev-haskell/crypto-random-0.0.7:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/cprng-aes/metadata.xml b/dev-haskell/cprng-aes/metadata.xml
new file mode 100644
index 000000000000..bd92a85d655f
--- /dev/null
+++ b/dev-haskell/cprng-aes/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Simple crypto pseudo-random-number-generator with really good randomness property.
+
+ Using ent, a randomness property maker on one 1Mb sample:
+ Entropy = 7.999837 bits per byte.
+ Optimum compression would reduce the size of this 1048576 byte file by 0 percent.
+ Chi square distribution for 1048576 samples is 237.02
+ Arithmetic mean value of data bytes is 127.3422 (127.5 = random)
+ Monte Carlo value for Pi is 3.143589568 (error 0.06 percent)
+
+ Compared to urandom with the same sampling:
+ Entropy = 7.999831 bits per byte.
+ Optimum compression would reduce the size of this 1048576 byte file by 0 percent.
+ Chi square distribution for 1048576 samples is 246.63
+ Arithmetic mean value of data bytes is 127.6347 (127.5 = random).
+ Monte Carlo value for Pi is 3.132465868 (error 0.29 percent).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-cprng-aes</remote-id>
+ </upstream>
+</pkgmetadata>