summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/crypto-cipher-tests
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/crypto-cipher-tests')
-rw-r--r--dev-haskell/crypto-cipher-tests/Manifest2
-rw-r--r--dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild34
-rw-r--r--dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11.ebuild34
-rw-r--r--dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.7.ebuild34
-rw-r--r--dev-haskell/crypto-cipher-tests/metadata.xml11
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-haskell/crypto-cipher-tests/Manifest b/dev-haskell/crypto-cipher-tests/Manifest
new file mode 100644
index 000000000000..d820edef8fec
--- /dev/null
+++ b/dev-haskell/crypto-cipher-tests/Manifest
@@ -0,0 +1,2 @@
+DIST crypto-cipher-tests-0.0.11.tar.gz 6183 SHA256 dfb670b73d4091b8683634d0d4d5a40576d573ad160650d5e518244ced8b98a7 SHA512 cc8361517e6c2afed1585e7648ed1143e8b4224918fbd8191a970d0afe2a162b759e8e6aee49308a93bdfe0d4d15e2bfb587d4e9f6891766f8e834822553b853 WHIRLPOOL 2f987c984cced4c0017223458284f3257a3172f1dfff87c0f3693b5015fcd483f1c3d4723a8d8ac00cc6eb40388d89ff6f0e3c832107e65f40f5e9c105863f3a
+DIST crypto-cipher-tests-0.0.7.tar.gz 5420 SHA256 9051e2e3e628ffcb1265a979d479f0bbf0534f2eb14aef95028a5a68321e8be2 SHA512 13f7cd09a491d13bc78f9aad5425b9fd919b007f794dd837e3504748b34b879c6193273f55244672fc85ecb2d40ff16ce98f23a7fa93daf0c052d64d3c026270 WHIRLPOOL 43b314e2165287a1427ef161587d846abef5e7eddae8a9c609d77772deda55799e7404d9c1918938a51fb6213c9d7d63bccf56776b26a3e26be5b340d4061b1c
diff --git a/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild
new file mode 100644
index 000000000000..9f21fd37ef07
--- /dev/null
+++ b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic cryptography cipher tests"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/byteable-0.1.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ >=dev-haskell/securemem-0.1.1:=[profile?] <dev-haskell/securemem-0.2:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11.ebuild b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11.ebuild
new file mode 100644
index 000000000000..b6cbffe09ec2
--- /dev/null
+++ b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic cryptography cipher tests"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/byteable-0.1.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/quickcheck-2:=[profile?]
+ >=dev-haskell/securemem-0.1.1:=[profile?] <dev-haskell/securemem-0.2:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.7.ebuild b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.7.ebuild
new file mode 100644
index 000000000000..1cd4aa7851c1
--- /dev/null
+++ b/dev-haskell/crypto-cipher-tests/crypto-cipher-tests-0.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic cryptography cipher tests"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/byteable-0.1.1:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.5:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/quickcheck-2:=[profile?]
+ >=dev-haskell/securemem-0.1.1:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/crypto-cipher-tests/metadata.xml b/dev-haskell/crypto-cipher-tests/metadata.xml
new file mode 100644
index 000000000000..8c507b94afd9
--- /dev/null
+++ b/dev-haskell/crypto-cipher-tests/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Generic cryptography cipher tests
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>