summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-31 06:49:53 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:18 +0100
commit4b56cd93edaf96c6496350d4c337035fd3606ff4 (patch)
treedac544855076757cca2ac1b8a2fcc27f0929cc20 /dev-haskell/cryptohash-sha256
parentdev-haskell/uuid-types: loosen dependency upper bounds (diff)
downloadgentoo-4b56cd93edaf96c6496350d4c337035fd3606ff4.tar.gz
gentoo-4b56cd93edaf96c6496350d4c337035fd3606ff4.tar.bz2
gentoo-4b56cd93edaf96c6496350d4c337035fd3606ff4.zip
dev-haskell/cryptohash-sha256: bump up to 0.11.101.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/cryptohash-sha256')
-rw-r--r--dev-haskell/cryptohash-sha256/Manifest1
-rw-r--r--dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-sha256/Manifest b/dev-haskell/cryptohash-sha256/Manifest
index 26caeeeeae2a..dbc621d43275 100644
--- a/dev-haskell/cryptohash-sha256/Manifest
+++ b/dev-haskell/cryptohash-sha256/Manifest
@@ -1 +1,2 @@
DIST cryptohash-sha256-0.11.100.1.tar.gz 10885 BLAKE2B 09f33b351b72bb9b8892409b5b140bd446f98cb7fdc349f483a3b719753c0a0ca08c0557ccff2bc4bfedb4336b3c5d046d15548cc8e3a404d69efcf2a5c744c2 SHA512 df6a8c7a4796f3b94faf0c1073b552eccf7dfbe6ab1489fef391e6342f34b3cb29991d1313aa5da11a90cb37bcd43c23eea12073ad4c7190926005de952c39e2
+DIST cryptohash-sha256-0.11.101.0.tar.gz 14996 BLAKE2B 9caccc3eea4ad25c6ebbdd507771d86264a853f282d03399917b42a5311dcad0501bd0b4ea6fa00d039f67bcea3f81c116b9ec016d65cb2ed6f086b0448894c0 SHA512 c755f1354fb5f1d6cfb54f73e39692392517954118d98b39ac4be7460e75a9ddc91ad641fed0f17e5fa33b62b7b0734af66526ea757e00716832572bb383c612
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild
new file mode 100644
index 000000000000..7dea0e17ebb0
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4.9999
+#hackport: flags: -exe
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-256 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha256"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+ test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.11' 'base >= 4.5' \
+ 'tasty == 0.11.*' 'tasty >= 0.11' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-exe
+}