summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/diff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/diff')
-rw-r--r--dev-haskell/diff/Manifest4
-rw-r--r--dev-haskell/diff/diff-0.1.3.ebuild28
-rw-r--r--dev-haskell/diff/diff-0.3.0.ebuild28
-rw-r--r--dev-haskell/diff/diff-0.3.1.ebuild31
-rw-r--r--dev-haskell/diff/diff-0.3.2.ebuild30
-rw-r--r--dev-haskell/diff/metadata.xml8
6 files changed, 129 insertions, 0 deletions
diff --git a/dev-haskell/diff/Manifest b/dev-haskell/diff/Manifest
new file mode 100644
index 000000000000..fe3dfef2411f
--- /dev/null
+++ b/dev-haskell/diff/Manifest
@@ -0,0 +1,4 @@
+DIST Diff-0.1.3.tar.gz 2851 SHA256 bc40377de386ee27e823c1427be0590c23286c6c3307387aa97fd67133f1b009 SHA512 6959d9fcd6f7a59b4a32779e8c96723b7219dd0a3b70a61a996d375825c84a8626de79cef9135d4ee8d24599ebdb4ba525a1a11234ade8b70278282f1544370e WHIRLPOOL 88c75ea7915c87a0313fb4820a5dd1261f9df407e65aa2e772bcfb97c0d292c35528d4431164ae48e75bb477be0d8e57b2367a032f3859db96146bf68f3c5b8a
+DIST Diff-0.3.0.tar.gz 4128 SHA256 28f96d7f4bb0f88a13fa0b59e89cc8b93fa901c6cbe6ca82e84540cb2291ee4c SHA512 6920802ba715a97f7650e8edbcc8469c1479d8be2c7fb61703fccaf77f4adc23ced7d26794e6210318afd98f350bc5cb08fd70c1b2797fde9f95546e55a85198 WHIRLPOOL 207533f86812388eb6db9fc52f60c75eb66b0c79cea35a805e85c22e5784838c0196a320f3109fcf9c9aed866c0a0c1df5fe53be8745ff8113160b84fef99dce
+DIST Diff-0.3.1.tar.gz 5138 SHA256 2ebae93784c0a3735291a378404adc07b1a3a493d88217c2240a8f56d7f24a83 SHA512 d07afd01417a2f4a9d5f33910ba49fd06a522a127d2c78a4092505e13ad0bd367362f3ddffad5ced9b573e4477395ddc58e4b3d028de70837437762b44c376f6 WHIRLPOOL f1cc965af5ae5ef86ec925f5afaeff89187af6a31912956bb0c38e61641a92fbc51eaa98b8d9eb2ef69524a10542c46394412d61056568e5bc9a468f1b9d013d
+DIST Diff-0.3.2.tar.gz 5024 SHA256 7f032b9842228c2282a66d096e0c943b830138493fbbc5f176a7b2a66ec5388e SHA512 b41c8482b1bcd4e332f85015f7ea99dc3c76d106327bf6b3a8676bb31ffbbdc80f09386f8044aae234a1be6a6304ec4860bb9c0ced95f8910db19d3e2cefe297 WHIRLPOOL a32fce5c63bf40fec7ba9d743a6e577285c1044b8efca24a557ac32115d0fb534554715510d0e9f4565407fdcb00ac2a8d02b89a68024c8035d0d57bde14d123
diff --git a/dev-haskell/diff/diff-0.1.3.ebuild b/dev-haskell/diff/diff-0.1.3.ebuild
new file mode 100644
index 000000000000..4cba1cdefeeb
--- /dev/null
+++ b/dev-haskell/diff/diff-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Diff"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="O(ND) diff algorithm in haskell"
+HOMEPAGE="http://hackage.haskell.org/package/Diff"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/diff/diff-0.3.0.ebuild b/dev-haskell/diff/diff-0.3.0.ebuild
new file mode 100644
index 000000000000..0bd080b28853
--- /dev/null
+++ b/dev-haskell/diff/diff-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Diff"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="O(ND) diff algorithm in haskell"
+HOMEPAGE="http://hackage.haskell.org/package/Diff"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/diff/diff-0.3.1.ebuild b/dev-haskell/diff/diff-0.3.1.ebuild
new file mode 100644
index 000000000000..76c1835fa80f
--- /dev/null
+++ b/dev-haskell/diff/diff-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Diff"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="O(ND) diff algorithm in haskell"
+HOMEPAGE="http://hackage.haskell.org/package/Diff"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#hackport: flag: -small-base
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/diff/diff-0.3.2.ebuild b/dev-haskell/diff/diff-0.3.2.ebuild
new file mode 100644
index 000000000000..22f57d795310
--- /dev/null
+++ b/dev-haskell/diff/diff-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Diff"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="O(ND) diff algorithm in haskell"
+HOMEPAGE="http://hackage.haskell.org/package/Diff"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/diff/metadata.xml b/dev-haskell/diff/metadata.xml
new file mode 100644
index 000000000000..9d7f1bde2f1e
--- /dev/null
+++ b/dev-haskell/diff/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Basic implementation of the standard diff algorithm.
+ </longdescription>
+</pkgmetadata>