summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-23 23:30:36 +0100
committerSam James <sam@gentoo.org>2022-07-23 23:47:38 +0100
commit5362f927c469032531d761895503e6ffa5475406 (patch)
tree487758366e485e38ad077bd0f0d3c5ee48143544 /dev-haskell/feed
parentapp-metrics/prometheus: stabilize 2.36.2 for amd64 (diff)
downloadgentoo-5362f927c469032531d761895503e6ffa5475406.tar.gz
gentoo-5362f927c469032531d761895503e6ffa5475406.tar.bz2
gentoo-5362f927c469032531d761895503e6ffa5475406.zip
dev-haskell/feed: add 1.3.2.1 (sync with ::gentoo)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/feed')
-rw-r--r--dev-haskell/feed/Manifest1
-rw-r--r--dev-haskell/feed/feed-1.3.2.1.ebuild39
-rw-r--r--dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch18
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/feed/Manifest b/dev-haskell/feed/Manifest
index 29c505411fc1..ec7e76688603 100644
--- a/dev-haskell/feed/Manifest
+++ b/dev-haskell/feed/Manifest
@@ -1 +1,2 @@
DIST feed-1.3.0.1.tar.gz 107230 BLAKE2B 5ed36f28c63e2af4669a37cac0715891b96d37570dfa99404df5764ad1e5b4e512d3d1a54e263c838875cc4a29ce00b3a022b3a2647983cbda4011ba5accd855 SHA512 73662018affac036bcd3c48a8a5b6fcd4e752231d805c12e977c6097a47691c2eca07eb8d6e6840a592bf35892b4b4ec44fb1f73f8a14ecb47fc6904b406f767
+DIST feed-1.3.2.1.tar.gz 107015 BLAKE2B 4a40441b17f50b9e7d43aee629fa0bc44f5b5cd1ca6281f3f5a8930b9cc5c2acdbdff05e9db4cc96c0e40681ecb15896655d8bbc708dc0bc4e3734b6e9f563bd SHA512 2175201ff9eaab5732e1c4e8dda6a35e8fa0dea5c58cd379348c97cd61a5eaf76e88f8d58d22df0a4b16681017e7ad01657ad60a63d90dab88df3b644ccb1ea0
diff --git a/dev-haskell/feed/feed-1.3.2.1.ebuild b/dev-haskell/feed/feed-1.3.2.1.ebuild
new file mode 100644
index 000000000000..3204f130059b
--- /dev/null
+++ b/dev-haskell/feed/feed-1.3.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds"
+HOMEPAGE="https://github.com/haskell-party/feed"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.2.1-disable-doctest.patch" )
+
+RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?] <dev-haskell/base-compat-0.13:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/old-time-1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
+ <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/xml-conduit-1.3:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-haskell/xml-types-0.3.6:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/doctest
+ >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/markdown-unlit-0.4 <dev-haskell/markdown-unlit-0.6
+ dev-haskell/syb
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4 )
+"
diff --git a/dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch b/dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch
new file mode 100644
index 000000000000..01ebc6537499
--- /dev/null
+++ b/dev-haskell/feed/files/feed-1.3.2.1-disable-doctest.patch
@@ -0,0 +1,18 @@
+From: hololeap <hololeap@protonmail.com>
+Signed-off-by: hololeap <hololeap@protonmail.com>
+
+These doctests are difficult to run successfully and aren't worth the effort.
+
+diff -urN feed-1.3.2.1/feed.cabal feed-1.3.2.1-r1/feed.cabal
+--- feed-1.3.2.1/feed.cabal 2022-03-28 20:36:31.561223247 -0600
++++ feed-1.3.2.1-r1/feed.cabal 2022-03-28 21:05:49.501202376 -0600
+@@ -153,8 +153,7 @@
+ main-is: doctest-driver.hs
+ type: exitcode-stdio-1.0
+ default-language: Haskell2010
+- if impl(ghc < 8)
+- buildable: False
++ buildable: False
+ build-depends:
+ base >= 4.6
+ , doctest