summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:45:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:57:12 +0000
commitdfcccfc340d82c82f1d712b52d093300557016a2 (patch)
tree084a69a709340821e62bf5430a319005b3c593f4 /dev-haskell/glib/glib-0.13.4.1.ebuild
parentdev-haskell/mono-traversable: bump up to 1.0.1.1 (diff)
downloadgentoo-dfcccfc340d82c82f1d712b52d093300557016a2.tar.gz
gentoo-dfcccfc340d82c82f1d712b52d093300557016a2.tar.bz2
gentoo-dfcccfc340d82c82f1d712b52d093300557016a2.zip
dev-haskell/glib: bump up to 0.13.4.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/glib/glib-0.13.4.1.ebuild')
-rw-r--r--dev-haskell/glib/glib-0.13.4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/glib/glib-0.13.4.1.ebuild b/dev-haskell/glib/glib-0.13.4.1.ebuild
new file mode 100644
index 000000000000..67b615db0ba4
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+closure_signals"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure_signals closure_signals)
+}