summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 09:58:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:59 +0000
commit541cb055f488407ea7e9f75e2cc7226c13a4f0f8 (patch)
tree8c99929c7b061cb476fbf4e6b5b9c4da29446c78 /dev-haskell/glob/glob-0.7.14.ebuild
parentdev-haskell/uuid-types: allow quickcheck-2.9 (diff)
downloadgentoo-541cb055f488407ea7e9f75e2cc7226c13a4f0f8.tar.gz
gentoo-541cb055f488407ea7e9f75e2cc7226c13a4f0f8.tar.bz2
gentoo-541cb055f488407ea7e9f75e2cc7226c13a4f0f8.zip
dev-haskell/glob: bump up to 0.7.14
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/glob/glob-0.7.14.ebuild')
-rw-r--r--dev-haskell/glob/glob-0.7.14.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/glob/glob-0.7.14.ebuild b/dev-haskell/glob/glob-0.7.14.ebuild
new file mode 100644
index 000000000000..7b0200220111
--- /dev/null
+++ b/dev-haskell/glob/glob-0.7.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="Glob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Globbing library"
+HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.4:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.6:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.6
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/test-framework-0.2 <dev-haskell/test-framework-1
+ >=dev-haskell/test-framework-hunit-0.2 <dev-haskell/test-framework-hunit-1
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-1 )
+"
+
+S="${WORKDIR}/${MY_P}"