summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-06 12:44:32 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-06 12:44:32 +0100
commitc493ede086ca8db0a74d87c53b25c03d5c03aa80 (patch)
treeef76c5f9122fe2e4c6e39977a2e88e511978038b /dev-haskell/gtk3
parentdev-haskell/glade: drop old (diff)
downloadgentoo-c493ede086ca8db0a74d87c53b25c03d5c03aa80.tar.gz
gentoo-c493ede086ca8db0a74d87c53b25c03d5c03aa80.tar.bz2
gentoo-c493ede086ca8db0a74d87c53b25c03d5c03aa80.zip
dev-haskell/gtk3: add a workaround against glib-2.62
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/gtk3')
-rw-r--r--dev-haskell/gtk3/files/gtk3-0.14.9-glib-2.62.patch11
-rw-r--r--dev-haskell/gtk3/gtk3-0.14.9-r3.ebuild50
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/gtk3/files/gtk3-0.14.9-glib-2.62.patch b/dev-haskell/gtk3/files/gtk3-0.14.9-glib-2.62.patch
new file mode 100644
index 000000000000..da921a2cf415
--- /dev/null
+++ b/dev-haskell/gtk3/files/gtk3-0.14.9-glib-2.62.patch
@@ -0,0 +1,11 @@
+--- a/gtk3.cabal
++++ b/gtk3.cabal
+@@ -372,7 +372,7 @@ Library
+ -- needs to be imported from this module:
+ x-Signals-Import: Graphics.UI.Gtk.General.Threading
+ include-dirs: .
+- cpp-options: -DDISABLE_DEPRECATED -U__BLOCKS__
++ cpp-options: -DDISABLE_DEPRECATED -U__BLOCKS__ -D__attribute__(A)=
+ if os(darwin) || os(freebsd)
+ cpp-options: -D__attribute__(A)= -D_Nullable= -D_Nonnull=
+ if os(windows)
diff --git a/dev-haskell/gtk3/gtk3-0.14.9-r3.ebuild b/dev-haskell/gtk3/gtk3-0.14.9-r3.ebuild
new file mode 100644
index 000000000000..c42fc3fe4dc0
--- /dev/null
+++ b/dev-haskell/gtk3/gtk3-0.14.9-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.5.9999
+#hackport: flags: have-gio:gio,build-demos:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ 3 graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.3
+ >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+ virtual/pkgconfig
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.14.9-glib-2.62.patch)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.24 && < 2.3' 'Cabal >= 1.24 && < 3.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-gio)
+}