summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:31:55 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:56 +0100
commit982d43499bca8b249cfbb6be7080b1ced722c465 (patch)
tree9e2075e650bf5f08bdd89fa4304e08e2f6c9ec7a /dev-haskell/hans
parentdev-haskell/monadlib: add package (diff)
downloadgentoo-982d43499bca8b249cfbb6be7080b1ced722c465.tar.gz
gentoo-982d43499bca8b249cfbb6be7080b1ced722c465.tar.bz2
gentoo-982d43499bca8b249cfbb6be7080b1ced722c465.zip
dev-haskell/hans: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hans')
-rw-r--r--dev-haskell/hans/Manifest1
-rw-r--r--dev-haskell/hans/hans-3.0.1.ebuild45
-rw-r--r--dev-haskell/hans/metadata.xml13
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/hans/Manifest b/dev-haskell/hans/Manifest
new file mode 100644
index 000000000000..3138ec0e3c90
--- /dev/null
+++ b/dev-haskell/hans/Manifest
@@ -0,0 +1 @@
+DIST hans-3.0.1.tar.gz 102002 BLAKE2B 2344c30c2143c38b77316cb34b35b38b9228452ca1a5ef0ebf2faf6f74d66a4a264db1f4d336ae86f5ab467cde4c2a914af22cc222110f649ede0bdecaadf5d4 SHA512 4495feb3bad78e8502bf1213727a130cc4e190dae54c1876ab353a919bfbce8e2fc370f3a191223e92944b3dbbba8a57e69c126d70c4ba65801eeb22a4edb55d
diff --git a/dev-haskell/hans/hans-3.0.1.ebuild b/dev-haskell/hans/hans-3.0.1.ebuild
new file mode 100644
index 000000000000..8095c489a087
--- /dev/null
+++ b/dev-haskell/hans/hans-3.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Network Stack"
+HOMEPAGE="http://hackage.haskell.org/package/hans"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT=test # some test did not survive QC-2.10 (unicode string generator)
+
+RDEPEND="dev-haskell/boundedchan:=[profile?]
+ >=dev-haskell/cereal-0.5.0.0:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/heaps:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/monadlib:=[profile?]
+ dev-haskell/psqueues:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+ test? ( dev-haskell/quickcheck
+ >=dev-haskell/tasty-0.11
+ dev-haskell/tasty-ant-xml
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}
diff --git a/dev-haskell/hans/metadata.xml b/dev-haskell/hans/metadata.xml
new file mode 100644
index 000000000000..0c6e0b4ba623
--- /dev/null
+++ b/dev-haskell/hans/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ HaNS is a lightweight, pure Haskell network stack that can be used for Haskell
+ networking in the context of the HaLVM, or with a Linux tap device. Currently,
+ HaNS supports 802.3, IPv4, ARP, DHCP (partially), ICMP, UDP, and TCP.
+ </longdescription>
+</pkgmetadata>