summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-06-04 14:54:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-06-04 14:55:02 +0100
commitefd783c3877ba62bb52b68e7098efd7b82142201 (patch)
treeffe53bd1901eb95d0bbc566de0cfcdecf353af7e /dev-haskell/hashtables
parentmedia-gfx/imv: added missing deps for the test phase #583836 (diff)
downloadgentoo-efd783c3877ba62bb52b68e7098efd7b82142201.tar.gz
gentoo-efd783c3877ba62bb52b68e7098efd7b82142201.tar.bz2
gentoo-efd783c3877ba62bb52b68e7098efd7b82142201.zip
dev-haskell/hashtables: drop broken USE=debug flag, bug #584908
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/584908 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-haskell/hashtables')
-rw-r--r--dev-haskell/hashtables/hashtables-1.1.2.1.ebuild5
-rw-r--r--dev-haskell/hashtables/hashtables-1.2.1.0.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild b/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
index cd9d4af92179..5d1444566ae7 100644
--- a/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
+++ b/dev-haskell/hashtables/hashtables-1.1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="bounds-checking debug portable cpu_flags_x86_sse4_1 +unsafe-tricks"
+IUSE="bounds-checking portable cpu_flags_x86_sse4_1 +unsafe-tricks"
RDEPEND="dev-haskell/primitive:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
@@ -30,7 +30,6 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bounds-checking bounds-checking) \
- $(cabal_flag debug debug) \
$(cabal_flag portable portable) \
$(cabal_flag cpu_flags_x86_sse4_1 sse41) \
$(cabal_flag unsafe-tricks unsafe-tricks)
diff --git a/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild b/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild
index d039c9459301..626bc9867d16 100644
--- a/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild
+++ b/dev-haskell/hashtables/hashtables-1.2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="bounds-checking cpu_flags_x86_sse4_2 debug portable +unsafe-tricks"
+IUSE="bounds-checking cpu_flags_x86_sse4_2 portable +unsafe-tricks"
RDEPEND="dev-haskell/primitive:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
@@ -31,7 +31,6 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bounds-checking bounds-checking) \
- $(cabal_flag debug debug) \
$(cabal_flag portable portable) \
$(cabal_flag cpu_flags_x86_sse4_2 sse42) \
$(cabal_flag unsafe-tricks unsafe-tricks)