summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-17 22:10:00 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-17 22:10:22 +0100
commit1ac14e8691705d7bedfe58bc78a97ba60c53a655 (patch)
treeb244beaf661772c7cd475972b2b1a4954e9dafb2 /dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r4.ebuild
parentdev-haskell/hsql-mysql: move off virtual/mysql, bug #665868 (diff)
downloadgentoo-1ac14e8691705d7bedfe58bc78a97ba60c53a655.tar.gz
gentoo-1ac14e8691705d7bedfe58bc78a97ba60c53a655.tar.bz2
gentoo-1ac14e8691705d7bedfe58bc78a97ba60c53a655.zip
dev-haskell/hdbc-mysql: move off virtual/mysql, bug #665866
Move off virtual/mysql to dev-db/mysql-connector-c as a library provider (with proper subslot). Reported-by: Brian Evans Closes: https://bugs.gentoo.org/665866 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r4.ebuild')
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r4.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r4.ebuild
new file mode 100644
index 000000000000..2ec895f2184f
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
+inherit haskell-cabal
+
+MY_PN="HDBC-mysql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL driver for HDBC"
+HOMEPAGE="https://github.com/bos/hdbc-mysql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-cabal-1.18.patch
+ "${FILESDIR}/${P}"-extralib.patch
+)