summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-30 08:39:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-30 08:39:27 +0100
commit1a15cea15c08b516a1a53d2aaf601100b7599098 (patch)
tree6cee904f8281c3426fdd1db5cba6e098f0792307 /dev-haskell/hdbc-mysql
parentsci-electronics/xnec2c: Bump EAPI, fix QA problems (diff)
downloadgentoo-1a15cea15c08b516a1a53d2aaf601100b7599098.tar.gz
gentoo-1a15cea15c08b516a1a53d2aaf601100b7599098.tar.bz2
gentoo-1a15cea15c08b516a1a53d2aaf601100b7599098.zip
dev-haskell/hdbc-mysql: tweak for cabal-3
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/735956 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hdbc-mysql')
-rw-r--r--dev-haskell/hdbc-mysql/files/hdbc-mysql-0.7.1.0-cabal-3.patch11
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild4
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.7.1.0-cabal-3.patch b/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.7.1.0-cabal-3.patch
new file mode 100644
index 000000000000..11fe2231d73e
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.7.1.0-cabal-3.patch
@@ -0,0 +1,11 @@
+--- a/Setup.lhs
++++ b/Setup.lhs
+@@ -35,7 +35,7 @@ mysqlConfigProgram = (simpleProgram "mysql_config") {
+
+ mysqlBuildInfo :: LocalBuildInfo -> IO BuildInfo
+ mysqlBuildInfo lbi = do
+- let mysqlConfig = rawSystemProgramStdoutConf verbosity mysqlConfigProgram (withPrograms lbi)
++ let mysqlConfig = getDbProgramOutput verbosity mysqlConfigProgram (withPrograms lbi)
+ ws = " \n\r\t"
+
+ includeDirs <- return . map (drop 2) . split ws =<< mysqlConfig ["--include"]
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
index 5a09fbb7663b..b1a0712a1a16 100644
--- a/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.7.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}"/${P}-cabal-3.patch)
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag debug debug)