summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:37:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-20 09:38:13 +0100
commit346697420ffcb442cf97c41687c31a9b4bbf6e0d (patch)
treebfb747bb36dbafb02a803550eb2c02c1abb566fa /dev-haskell/hdbc-odbc
parentdev-python/hypothesis: Bump to 5.26.1 (diff)
downloadgentoo-346697420ffcb442cf97c41687c31a9b4bbf6e0d.tar.gz
gentoo-346697420ffcb442cf97c41687c31a9b4bbf6e0d.tar.bz2
gentoo-346697420ffcb442cf97c41687c31a9b4bbf6e0d.zip
dev-haskell/hdbc-odbc: bump up to 2.6.0.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hdbc-odbc')
-rw-r--r--dev-haskell/hdbc-odbc/Manifest1
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-odbc/Manifest b/dev-haskell/hdbc-odbc/Manifest
index d6df0a9cd61c..e9e419aff9e3 100644
--- a/dev-haskell/hdbc-odbc/Manifest
+++ b/dev-haskell/hdbc-odbc/Manifest
@@ -1 +1,2 @@
DIST HDBC-odbc-2.4.0.1.tar.gz 27185 BLAKE2B 5ccd40f9dcc3ee7045f8719b16f0d65f049cd52c323b86aebdc11fba7c9003747f29850aec059d4d092826c579e0f9dc2f9d12dbbf7b1e261ca052a3e5ba122a SHA512 ae9f5ac2aa6adfc155999fb78b35a12e381d1589bf2539306a4e346af4eee401db8af8ef74348cc0707620f9586367701505d0d61bd96f00f0ebeb9240ed9a06
+DIST HDBC-odbc-2.6.0.0.tar.gz 28537 BLAKE2B a3055d837406cd97586448c921738ae1bf05360fe4dc11d28f931c8020899c53ba83924f377945865c17b787eb32658a881136e19be1bd2a45a51b4766e4faa1 SHA512 300ee4b14a9cf1392d32549d17f3bb46e4dff22c0c5c8fc6a235dd76cb8dae2d722c3094bcd191ca146381c23259678b0735a7fb3a2d6527122d2a7a7e4db0d4
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild
new file mode 100644
index 000000000000..d0afebe0c643
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-2.6.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests,-buildstresstest
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-odbc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ODBC driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-odbc"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/unixODBC
+ >=dev-haskell/concurrent-extra-0.7.0.8:=[profile?]
+ >=dev-haskell/hdbc-2.1.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ virtual/libc
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-buildstresstest \
+ --flag=-buildtests
+}