summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 20:42:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:56:53 +0000
commitbcd30d91328b5e4b2bdac8e52dab17c4c86921a6 (patch)
tree3e93c08d788b2752412c407c419fd120bbffad79 /dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.4-r1.ebuild
parentdev-haskell/aeson: bump up to 1.0.2.1 (diff)
downloadgentoo-bcd30d91328b5e4b2bdac8e52dab17c4c86921a6.tar.gz
gentoo-bcd30d91328b5e4b2bdac8e52dab17c4c86921a6.tar.bz2
gentoo-bcd30d91328b5e4b2bdac8e52dab17c4c86921a6.zip
dev-haskell/hdbc-postgresql: bump up to 2.3.2.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.4-r1.ebuild')
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.4-r1.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.4-r1.ebuild
new file mode 100644
index 000000000000..231cc147c0b7
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: +splitbase
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="https://github.com/hdbc/hdbc-postgresql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/postgresql-7:*
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/hdbc-2.2.0:2=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase
+}