summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hdbc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hdbc')
-rw-r--r--dev-haskell/hdbc/Manifest3
-rw-r--r--dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-1.patch39
-rw-r--r--dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-2.patch43
-rw-r--r--dev-haskell/hdbc/hdbc-2.3.1.2.ebuild62
-rw-r--r--dev-haskell/hdbc/hdbc-2.4.0.0.ebuild68
-rw-r--r--dev-haskell/hdbc/hdbc-2.4.0.1.ebuild59
-rw-r--r--dev-haskell/hdbc/metadata.xml14
7 files changed, 288 insertions, 0 deletions
diff --git a/dev-haskell/hdbc/Manifest b/dev-haskell/hdbc/Manifest
new file mode 100644
index 000000000000..9ab44fb02aed
--- /dev/null
+++ b/dev-haskell/hdbc/Manifest
@@ -0,0 +1,3 @@
+DIST HDBC-2.3.1.2.tar.gz 23314 SHA256 07c962ebaf94f15df65dc0da875bda370abd2d163ab3fe3a946931dd11ac4ae6 SHA512 e98ca4043c311eb8e5adb02d1a59bc0d1be84ba66c224b848649a596de214a2a38b8bedfe71fa8f17ae0843cf073e814c76e7e868aca1e20619e3d5fa573109c WHIRLPOOL 76e909d4ac6ef0dce33a2771c7dba864b0e863251c76e8b9e97f706bbe36f78af566d8ec5e0bc4779161bae91528c8f6bddd7f8fdfe941d00a3f750f1d238eac
+DIST HDBC-2.4.0.0.tar.gz 23076 SHA256 de60f6881c9f613931bce3615b57bf4375a4fbc8520b5b8e17b1bf7541ce93ff SHA512 1a02a9ee2ed52e534ad4040f18c1335c41e815940921fe24f447a52dbcea889fca1fc65a4e805f8d283bab1180437db7912db625dbd042bc692d07a5131b0f71 WHIRLPOOL f7a78563206fade4b99e2b2947e01d7239ec36fb4d9ab1a00c8536f0ec950adde64f87b9e82b8a35c3c73977ca784774b2ef47c5c58073bd0b0f2bf1056d9eac
+DIST HDBC-2.4.0.1.tar.gz 23415 SHA256 7a3ee21c41e716111c4a3742a66eb448683719a9384afbf7021c5942ac73d2ad SHA512 1a20a533ffe7700cfb48c9875e9c6b09f940c1b808fd1a371327eed9c358abfe0167d206bb5b2dbb904b49f2081f91f81091d4164aad2aa08555f6de01a55d5a WHIRLPOOL 9c375d0828c1deb7d97a1312d56a41543aa342480965e39f73dd68fef79f5c68c30159f94ebf3bc2a8f80eb3a41ea08618ba499ef61cfa41725cb4507062b8f0
diff --git a/dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-1.patch b/dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-1.patch
new file mode 100644
index 000000000000..6b79476b6662
--- /dev/null
+++ b/dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-1.patch
@@ -0,0 +1,39 @@
+diff --git a/Database/HDBC/Locale.hs b/Database/HDBC/Locale.hs
+index e62b1c1..976a6a9 100644
+--- a/Database/HDBC/Locale.hs
++++ b/Database/HDBC/Locale.hs
+@@ -1,3 +1,4 @@
++{-# LANGUAGE CPP #-}
+ module Database.HDBC.Locale
+ (
+ defaultTimeLocale,
+@@ -5,7 +6,12 @@ module Database.HDBC.Locale
+ )
+
+ where
++
++#if MIN_VERSION_time(1,5,0)
++import Data.Time.Format (defaultTimeLocale)
++#else
+ import System.Locale (defaultTimeLocale)
++#endif
+
+ -- | As the semantic of System.Locale.iso8601DateFormat has changed with
+ -- old-locale-1.0.0.2 in a non-compatible way, we now define our own
+diff --git a/Database/HDBC/SqlValue.hs b/Database/HDBC/SqlValue.hs
+index 9724f81..0e278cd 100644
+--- a/Database/HDBC/SqlValue.hs
++++ b/Database/HDBC/SqlValue.hs
+@@ -17,7 +17,11 @@ import Data.Char(ord,toUpper)
+ import Data.Word
+ import Data.Int
+ import qualified System.Time as ST
+-import Data.Time
++import Data.Time ( Day (ModifiedJulianDay), DiffTime, LocalTime, NominalDiffTime, ParseTime
++ , TimeOfDay, TimeZone, UTCTime, ZonedTime, formatTime, localDay, localTimeOfDay
++ , parseTime, timeOfDayToTime, timeToTimeOfDay, toModifiedJulianDay, utc
++ , utcToZonedTime, zonedTimeToLocalTime, zonedTimeToUTC, zonedTimeZone
++ )
+ import Data.Time.Clock.POSIX
+ import Database.HDBC.Locale (defaultTimeLocale, iso8601DateFormat)
+ import Data.Ratio
diff --git a/dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-2.patch b/dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-2.patch
new file mode 100644
index 000000000000..d4e78b6f8cd2
--- /dev/null
+++ b/dev-haskell/hdbc/files/hdbc-2.4.0.0-ghc-7.10-2.patch
@@ -0,0 +1,43 @@
+diff --git a/Database/HDBC/SqlValue.hs b/Database/HDBC/SqlValue.hs
+index 0e278cd..1ebf114 100644
+--- a/Database/HDBC/SqlValue.hs
++++ b/Database/HDBC/SqlValue.hs
+@@ -19,8 +19,13 @@ import Data.Int
+ import qualified System.Time as ST
+ import Data.Time ( Day (ModifiedJulianDay), DiffTime, LocalTime, NominalDiffTime, ParseTime
+ , TimeOfDay, TimeZone, UTCTime, ZonedTime, formatTime, localDay, localTimeOfDay
+- , parseTime, timeOfDayToTime, timeToTimeOfDay, toModifiedJulianDay, utc
++ , timeOfDayToTime, timeToTimeOfDay, toModifiedJulianDay, utc
+ , utcToZonedTime, zonedTimeToLocalTime, zonedTimeToUTC, zonedTimeZone
++#if MIN_VERSION_time(1,5,0)
++ , parseTimeM
++#else
++ , parseTime
++#endif
+ )
+ import Data.Time.Clock.POSIX
+ import Database.HDBC.Locale (defaultTimeLocale, iso8601DateFormat)
+@@ -665,7 +670,11 @@ instance Convertible (TimeOfDay, TimeZone) SqlValue where
+ instance Convertible SqlValue (TimeOfDay, TimeZone) where
+ safeConvert (SqlString x) =
+ do tod <- parseTime' "%T%Q %z" x
++#if MIN_VERSION_time(1,5,0)
++ tz <- case parseTimeM True defaultTimeLocale "%T%Q %z" x of
++#else
+ tz <- case parseTime defaultTimeLocale "%T%Q %z" x of
++#endif
+ Nothing -> convError "Couldn't extract timezone in" (SqlString x)
+ Just y -> Right y
+ return (tod, tz)
+@@ -939,7 +948,11 @@ parseTime' _ inpstr =
+ #else
+ parseTime' :: (Typeable t, Convertible SqlValue t, ParseTime t) => String -> String -> ConvertResult t
+ parseTime' fmtstr inpstr =
++#if MIN_VERSION_time(1,5,0)
++ case parseTimeM True defaultTimeLocale fmtstr inpstr of
++#else
+ case parseTime defaultTimeLocale fmtstr inpstr of
++#endif
+ Nothing -> convError ("Cannot parse using default format string " ++ show fmtstr)
+ (SqlString inpstr)
+ Just x -> Right x
diff --git a/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild b/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild
new file mode 100644
index 000000000000..edc32ad9b41f
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-2.3.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal versionator
+
+MY_PN="HDBC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="https://github.com/hdbc/hdbc"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql odbc postgres sqlite test"
+
+RDEPEND=">=dev-haskell/convertible-1.0.10.0:=[profile?] <dev-haskell/convertible-1.1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ )
+ "
+
+DEPENDV="$(get_version_component_range 1-2)"
+PDEPEND="mysql? ( dev-haskell/hdbc-mysql )
+ odbc? ( =dev-haskell/hdbc-odbc-${DEPENDV}* )
+ postgres? ( =dev-haskell/hdbc-postgresql-${DEPENDV}* )
+ sqlite? ( >=dev-haskell/hdbc-sqlite-${DEPENDV} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc/hdbc-2.4.0.0.ebuild b/dev-haskell/hdbc/hdbc-2.4.0.0.ebuild
new file mode 100644
index 000000000000..e9bb6d750deb
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-2.4.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: buildtests:test
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+MY_PN="HDBC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="https://github.com/hdbc/hdbc"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # Tests do not compile with time 1.5
+
+RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ >=dev-haskell/testpack-2.0 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-2.4.0.0-ghc-7.10-1.patch"
+ "${FILESDIR}/${PN}-2.4.0.0-ghc-7.10-2.patch")
+
+src_prepare() {
+ base_src_prepare
+ cabal_chdeps \
+ 'time>=1.1.3 && <=1.5' 'time>=1.1.3 && <=1.6'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild b/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild
new file mode 100644
index 000000000000..45949beb7efe
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: buildtests:test
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="https://github.com/hdbc/hdbc"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # Tests do not compile with time 1.5
+
+RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.0:2=[profile?]
+ >=dev-haskell/testpack-2.0:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}
diff --git a/dev-haskell/hdbc/metadata.xml b/dev-haskell/hdbc/metadata.xml
new file mode 100644
index 000000000000..607a1e4d0d53
--- /dev/null
+++ b/dev-haskell/hdbc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ HDBC provides an abstraction layer between Haskell programs and SQL
+ relational databases. This lets you write database code once, in
+ Haskell, and have it work with any number of backend SQL databases
+ (MySQL, Oracle, PostgreSQL, ODBC-compliant databases, etc.)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hdbc/hdbc</remote-id>
+ </upstream>
+</pkgmetadata>