summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-08-01 12:37:22 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:04:17 +0100
commiteff393a11700c6657455dc179a81c3ae89ea42e2 (patch)
treefa538177152d503e80c951189c91143d382a020f /dev-haskell/hex
parentdev-haskell/mmorph: bump up to 1.1.3 (diff)
downloadgentoo-eff393a11700c6657455dc179a81c3ae89ea42e2.tar.gz
gentoo-eff393a11700c6657455dc179a81c3ae89ea42e2.tar.bz2
gentoo-eff393a11700c6657455dc179a81c3ae89ea42e2.zip
dev-haskell/hex: patch for monadfail
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hex')
-rw-r--r--dev-haskell/hex/files/hex-0.1.2-monadfail.patch20
-rw-r--r--dev-haskell/hex/hex-0.1.2.ebuild6
-rw-r--r--dev-haskell/hex/metadata.xml3
3 files changed, 24 insertions, 5 deletions
diff --git a/dev-haskell/hex/files/hex-0.1.2-monadfail.patch b/dev-haskell/hex/files/hex-0.1.2-monadfail.patch
new file mode 100644
index 000000000000..27caaf0774f2
--- /dev/null
+++ b/dev-haskell/hex/files/hex-0.1.2-monadfail.patch
@@ -0,0 +1,20 @@
+--- hex-0.1.2/Data/Hex.hs 2011-10-11 05:44:11.000000000 +1100
++++ Data/Hex.hs 2020-08-01 12:28:49.166983032 +1000
+@@ -22,7 +22,7 @@
+ -- | Convert string into hexadecimal.
+ hex :: t -> t
+ -- | Convert from hexadecimal and fail on invalid input.
+- unhex :: Monad m => t -> m t
++ unhex :: (Monad m, MonadFail m) => t -> m t
+
+
+ instance Hex String where
+@@ -37,7 +37,7 @@
+ unhex [_] = fail "Non-even length"
+
+
+-c :: Monad m => Char -> m Int
++c :: (Monad m, MonadFail m) => Char -> m Int
+ c '0' = return 0
+ c '1' = return 1
+ c '2' = return 2
diff --git a/dev-haskell/hex/hex-0.1.2.ebuild b/dev-haskell/hex/hex-0.1.2.ebuild
index 766e8f4a5a41..f6d98cbeeb1e 100644
--- a/dev-haskell/hex/hex-0.1.2.ebuild
+++ b/dev-haskell/hex/hex-0.1.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
# ebuild generated by hackport 0.4.6.9999
@@ -9,7 +9,7 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Convert strings into hexadecimal and back"
-HOMEPAGE="https://hackage.haskell.org/package/hex"
+HOMEPAGE="http://hackage.haskell.org/package/hex"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
@@ -22,3 +22,5 @@ RDEPEND=">=dev-lang/ghc-7.4.1:=
DEPEND="${RDEPEND}
dev-haskell/cabal
"
+
+PATCHES=( "${FILESDIR}"/${P}-monadfail.patch )
diff --git a/dev-haskell/hex/metadata.xml b/dev-haskell/hex/metadata.xml
index 3154e9fd1185..b7878815d80d 100644
--- a/dev-haskell/hex/metadata.xml
+++ b/dev-haskell/hex/metadata.xml
@@ -5,7 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Convert strings into hexadecimal and back.
- </longdescription>
</pkgmetadata>