summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hexpat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hexpat')
-rw-r--r--dev-haskell/hexpat/Manifest1
-rw-r--r--dev-haskell/hexpat/hexpat-0.20.9.ebuild29
-rw-r--r--dev-haskell/hexpat/metadata.xml60
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-haskell/hexpat/Manifest b/dev-haskell/hexpat/Manifest
new file mode 100644
index 000000000000..1286e50a2bd8
--- /dev/null
+++ b/dev-haskell/hexpat/Manifest
@@ -0,0 +1 @@
+DIST hexpat-0.20.9.tar.gz 132649 SHA256 5d1c075f1ae00be2e80c0018b522a351b2f4ef73b9baca1113ee80e554449d9d SHA512 619bf92d60f2d43c11861507daf6f93716b5ed5c1fc1957a27470b65264d7c0b5edb3f6e2a1a9d25cd5d7edd8146abaf5cbb772f2d84dacd9f2fe9913b81b543 WHIRLPOOL b8be8167a12d9fbbd437c657d64564d9f510d2e7c0af5ccb1bbbd42168b6557dc692117213ed43f1af6fdd46870444a3db1f6a083e70f6904329a485e4683c6c
diff --git a/dev-haskell/hexpat/hexpat-0.20.9.ebuild b/dev-haskell/hexpat/hexpat-0.20.9.ebuild
new file mode 100644
index 000000000000..f3d2c780d18b
--- /dev/null
+++ b/dev-haskell/hexpat/hexpat-0.20.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="XML parser/formatter based on expat"
+HOMEPAGE="http://haskell.org/haskellwiki/Hexpat/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/list-0.4.2:=[profile?] <dev-haskell/list-0.6:=[profile?]
+ >=dev-haskell/text-0.5.0.0:=[profile?] <dev-haskell/text-1.3.0.0:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/hexpat/metadata.xml b/dev-haskell/hexpat/metadata.xml
new file mode 100644
index 000000000000..b086c39e8464
--- /dev/null
+++ b/dev-haskell/hexpat/metadata.xml
@@ -0,0 +1,60 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a general purpose Haskell XML library using Expat to
+ do its parsing (&lt;http://expat.sourceforge.net/&gt; - a fast stream-oriented XML
+ parser written in C). It is extensible to any string type, with @String@,
+ @ByteString@ and @Text@ provided out of the box.
+
+ Basic usage: Parsing a tree (/Tree/), formatting a tree (/Format/).
+ Other features: Helpers for processing XML trees (/Proc/), trees annotated with
+ XML source location (/Annotated/), extended XML trees with comments,
+ processing instructions, etc (/Extended/), XML cursors (/Cursor/),
+ SAX-style parse (/SAX/), and access to the low-level interface in case speed
+ is paramount (/Internal.IO/).
+
+ The design goals are speed, speed, speed, interface simplicity and modularity.
+
+ For introduction and examples, see the /Text.XML.Expat.Tree/ module. For benchmarks,
+ &lt;http://haskell.org/haskellwiki/Hexpat/&gt;
+
+ If you want to do interactive I\/O, an obvious option is to use lazy parsing
+ with one of the lazy I\/O functions such as hGetContents. However, this can be
+ problematic in some applications because it doesn&#39;t handle I\/O errors properly
+ and can give no guarantee of timely resource cleanup. In these cases, chunked
+ I\/O is a better approach: Take a look at the /hexpat-enumerator/ package.
+
+ /IO/ is filed under /Internal/ because it&#39;s low-level and most users won&#39;t want
+ it. The other /Internal/ modules are re-exported by /Annotated/, /Tree/ and /Extended/,
+ so you won&#39;t need to import them directly.
+
+ Credits to Iavor Diatchki and the @xml@ (XML.Light) package for /Proc/ and /Cursor/.
+ Thanks to the many contributors.
+
+ BOUND VS. UNBOUND THREADS: GHC (at least versions 6.12.X) will spawn threads
+ if you call a safe FFI callback from an unbound thread. This can get out of
+ control in a busy application. To avoid this, from version 0.19.1 we now delegate
+ processing to a single worker thread if the calling thread is not bound.
+ This essentially means that hexpat currently won&#39;t exploit multicores very well.
+ It also means that hexpat may be more efficient on threads spawned with forkOS
+ (to give you a bound thread) rather than forkIO.
+
+ ChangeLog: 0.15 changes intended to fix a (rare) \&quot;error: a C finalizer called back into Haskell.\&quot;
+ that seemed only to happen only on ghc6.12.X; 0.15.1 Fix broken Annotated parse;
+ 0.16 switch from mtl to transformers; 0.17 fix mapNodeContainer &amp; rename some things.;
+ 0.18 rename defaultEncoding to overrideEncoding. 0.18.3 formatG and indent were demanding list
+ items more than once (inefficient in chunked processing); 0.19 add Extended.hs;
+ 0.19.1 fix a memory leak introduced in 0.19, delegate parsing to bound thread
+ if unbound (see note above); 0.19.2 include expat source code so \&#39;cabal install\&#39; just works
+ on Linux, Mac and Windows (thanks Jacob Stanley); 0.19.3 fix misconfiguration of expat
+ which broke entity parsing; 0.19.4 bump version constraint for text; 0.19.5 bump text
+ to &lt; 0.12 and fix text-0.10.0.1 breakage; 0.19.6 dependency breakage with List;
+ 0.19.7 ghc-7.2.1 compatibility; 0.19.8 fix space leak on lazy parse under ghc-7.2.1
+ </longdescription>
+</pkgmetadata>