summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/highlighting-kate
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/highlighting-kate')
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.14.ebuild4
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild4
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.1.ebuild4
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild4
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild4
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild4
6 files changed, 12 insertions, 12 deletions
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.14.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.14.ebuild
index f6cc91235009..d28287c878b7 100644
--- a/dev-haskell/highlighting-kate/highlighting-kate-0.5.14.ebuild
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Syntax highlighting"
HOMEPAGE="https://github.com/jgm/highlighting-kate"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
index 6c914b777c5c..b22e6c8eab77 100644
--- a/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Syntax highlighting"
HOMEPAGE="https://github.com/jgm/highlighting-kate"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.1.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.1.ebuild
index 2187920079a2..1af61606b39f 100644
--- a/dev-haskell/highlighting-kate/highlighting-kate-0.6.1.ebuild
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Syntax highlighting"
HOMEPAGE="https://github.com/jgm/highlighting-kate"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
index afc142fa2366..badab5941959 100644
--- a/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Syntax highlighting"
HOMEPAGE="https://github.com/jgm/highlighting-kate"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild
index a3dc5a42c908..0bc60b85c97c 100644
--- a/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Syntax highlighting"
HOMEPAGE="https://github.com/jgm/highlighting-kate"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild
index 07fe060323fd..04567d105afe 100644
--- a/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Syntax highlighting"
HOMEPAGE="https://github.com/jgm/highlighting-kate"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/${PV}"