summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 18:51:32 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:18 +0000
commit56746a7d4c1c206592eb867998a91251700741f1 (patch)
treef824dcda22f373230e353cc9aca02cf7a1549b16 /dev-haskell/hspec-core
parentdev-haskell/hspec: add 2.9.4 (diff)
downloadgentoo-56746a7d4c1c206592eb867998a91251700741f1.tar.gz
gentoo-56746a7d4c1c206592eb867998a91251700741f1.tar.bz2
gentoo-56746a7d4c1c206592eb867998a91251700741f1.zip
dev-haskell/hspec-core: add 2.9.4
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hspec-core')
-rw-r--r--dev-haskell/hspec-core/Manifest1
-rw-r--r--dev-haskell/hspec-core/hspec-core-2.9.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/hspec-core/Manifest b/dev-haskell/hspec-core/Manifest
index 1601ec771bb8..1ec2d68bd0b0 100644
--- a/dev-haskell/hspec-core/Manifest
+++ b/dev-haskell/hspec-core/Manifest
@@ -1 +1,2 @@
DIST hspec-core-2.7.1.tar.gz 58835 BLAKE2B b6fa09a26c6adaf25f99d6fc3b1df80ea5407f6e8963c16473b4c98ccff694457131a9c7c35e5250beee47a03fb1c695d74f33be335623340a2d729b6221cdff SHA512 5ab0925566c3b6f05480bd4e464ca32e0a212b4b4ff439d02b3df5b75b23b45ca0c63bab8398ebeeedce0ba30bb653b1ea85df2b7e6e3a058cb4413dc1c53ee2
+DIST hspec-core-2.9.4.tar.gz 79521 BLAKE2B c403787898de2296506cd2906641c2d91f3a4cee4cdab69e7e63e2ebab26a5729b37e938001992cccc76930ad5d4e39c0f204064ea542a2ca979b58acce77fdd SHA512 55859f3a6db6ca855a560b7b16f001784a81f6a70061374d58841fe0d6bdb99e98b522df03677ea132222ad6c96b3fed8d87aedb96dfde5326b7e6fde238e387
diff --git a/dev-haskell/hspec-core/hspec-core-2.9.4.ebuild b/dev-haskell/hspec-core/hspec-core-2.9.4.ebuild
new file mode 100644
index 000000000000..a12e8531c44b
--- /dev/null
+++ b/dev-haskell/hspec-core/hspec-core-2.9.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Testing Framework for Haskell"
+HOMEPAGE="https://hspec.github.io/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
+ dev-haskell/call-stack:=[profile?]
+ >=dev-haskell/clock-0.7.1:=[profile?]
+ >=dev-haskell/hspec-expectations-0.8.2:=[profile?] <dev-haskell/hspec-expectations-0.8.3:=[profile?]
+ >=dev-haskell/hunit-1.6:=[profile?] <dev-haskell/hunit-1.7:=[profile?]
+ >=dev-haskell/quickcheck-2.13.1:2=[profile?]
+ >=dev-haskell/quickcheck-io-0.2.0:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/setenv:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?]
+ dev-haskell/tf-random:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/base-orphans
+ ~dev-haskell/hspec-meta-2.9.3
+ >=dev-haskell/quickcheck-2.14
+ >=dev-haskell/silently-1.2.4
+ dev-haskell/temporary )
+"